The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of Apache httpd: information disclosure via mod_auth_digest

Synthesis of the vulnerability 

An attacker can bypass access restrictions to data via mod_auth_digest of Apache httpd, in order to obtain sensitive information.
Impacted systems: Apache httpd, Mac OS X, Blue Coat CAS, Broadcom Content Analysis, Debian, Junos Space, openSUSE Leap, Solaris, VirtualBox, RHEL, JBoss EAP by Red Hat, Ubuntu.
Severity of this alert: 3/4.
Creation date: 13/07/2017.
Références of this alert: APPLE-SA-2017-09-25-1, bulletinjul2017, cpuoct2017, CVE-2017-9788, DLA-1028-1, DSA-3913-1, HT208144, HT208221, JSA10838, openSUSE-SU-2017:2016-1, RHSA-2017:2478-01, RHSA-2017:2479-01, RHSA-2017:2483-01, RHSA-2017:3113-01, RHSA-2017:3114-01, RHSA-2017:3193-01, RHSA-2017:3194-01, RHSA-2017:3195-01, RHSA-2017:3239-01, RHSA-2017:3240-01, SYMSA1457, USN-3370-1, USN-3370-2, VIGILANCE-VUL-23249.

Description of the vulnerability 

An attacker can bypass access restrictions to data via mod_auth_digest of Apache httpd, in order to obtain sensitive information.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This vulnerability note impacts software or systems such as Apache httpd, Mac OS X, Blue Coat CAS, Broadcom Content Analysis, Debian, Junos Space, openSUSE Leap, Solaris, VirtualBox, RHEL, JBoss EAP by Red Hat, Ubuntu.

Our Vigil@nce team determined that the severity of this cybersecurity vulnerability is important.

The trust level is of type confirmed by the editor, with an origin of internet client.

An attacker with a expert ability can exploit this computer threat note.

Solutions for this threat 

Apache httpd: version 2.4.27.
The version 2.4.27 is fixed:
  https://httpd.apache.org/

Apache httpd: version 2.2.34.
The version 2.2.34 is fixed:
  http://httpd.apache.org/

Apple macOS 10.12: version Security Update 2017-001.
The version Security Update 2017-001 is fixed:
  https://support.apple.com/

Apple macOS: version 10.13.
The version 10.13 is fixed:
  https://www.apple.com/support/downloads/

Apple macOS: version 10.13.1.
The version 10.13.1 is fixed:
  https://support.apple.com/

Apple MacOS X 10.11: version Security Update 2017-004.
The version Security Update 2017-004 is fixed:
  https://support.apple.com/

Debian 7: new apache2 packages.
New packages are available:
  Debian 7: apache2 2.2.22-13+deb7u10

Debian 8/9: new apache2 packages.
New packages are available:
  Debian 8: apache2 2.4.10-10+deb8u10
  Debian 9: apache2 2.4.25-3+deb9u2

Junos Space: fixed versions.
Fixed versions are indicated in information sources.

openSUSE Leap: new apache2 packages.
New packages are available:
  openSUSE Leap 42.2: apache2 2.4.23-8.9.1
  openSUSE Leap 42.3: apache2 2.4.23-13.1

Oracle Solaris: patch for third party software of July 2017 v4.
A patch is available:
  https://support.oracle.com/rs?type=doc&id=1448883.1
  11.3 SRU 24

Oracle VM VirtualBox: version 5.1.30.
The version 5.1.30 is fixed:
  https://www.virtualbox.org/

Red Hat JBoss EAP: patch.
A patch is available:
  https://access.redhat.com/jbossnetwork/restricted/listSoftware.html?product=appplatform&downloadType=securityPatches&version=6.4

Red Hat JBoss Web Server: patch.
A patch is available:
  https://access.redhat.com/jbossnetwork/restricted/listSoftware.html?product=webserver&downloadType=securityPatches&version=2.1.2

RHEL 6.9: new httpd packages.
New packages are available:
  RHEL 6: httpd 2.2.15-60.el6_9.5

RHEL 7.4: new httpd packages.
New packages are available:
  RHEL 7: httpd 2.4.6-67.el7_4.2

RHEL: new httpd24-httpd packages.
New packages are available:
  RHEL 6: httpd24-httpd 2.4.25-9.el6.1
  RHEL 7: httpd24-httpd 2.4.25-9.el7.1

Symantec Content and Malware Analysis: solution for Apache HTTP Server.
The solution is indicated in information sources.

Ubuntu: new apache2-bin packages.
New packages are available:
  Ubuntu 17.04: apache2-bin 2.4.25-3ubuntu2.2
  Ubuntu 16.04 LTS: apache2-bin 2.4.18-2ubuntu3.4
  Ubuntu 14.04 LTS: apache2-bin 2.4.7-1ubuntu4.17
  Ubuntu 12.04 ESM: apache2.2-bin 2.2.22-1ubuntu1.13
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides a systems vulnerabilities note. The Vigil@nce team tracks computer vulnerabilities impacting systems and applications.