The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of Apache httpd mod_http2: denial of service via H2Upgrade

Synthesis of the vulnerability 

An attacker can trigger a fatal error via mod_http2 H2Upgrade of Apache httpd, in order to trigger a denial of service.
Impacted systems: Apache httpd, Apache httpd Modules ~ not comprehensive, HP-UX, IBM i, openSUSE Leap, Oracle Communications, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Severity of this alert: 3/4.
Creation date: 02/04/2019.
Références of this alert: CERTFR-2019-AVI-141, cpuapr2020, CVE-2019-0197, HPESBUX03950, ibm10883380, openSUSE-SU-2019:1190-1, openSUSE-SU-2019:1209-1, openSUSE-SU-2019:1258-1, RHSA-2020:4751-01, SUSE-SU-2019:0873-1, SUSE-SU-2019:0878-1, SUSE-SU-2019:0888-1, SUSE-SU-2019:0888-2, SUSE-SU-2019:0889-1, USN-4113-1, USN-4113-2, VIGILANCE-VUL-28913.

Description of the vulnerability 

An attacker can trigger a fatal error via mod_http2 H2Upgrade of Apache httpd, in order to trigger a denial of service.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This computer threat announce impacts software or systems such as Apache httpd, Apache httpd Modules ~ not comprehensive, HP-UX, IBM i, openSUSE Leap, Oracle Communications, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Our Vigil@nce team determined that the severity of this computer vulnerability is important.

The trust level is of type confirmed by the editor, with an origin of internet client.

An attacker with a expert ability can exploit this cybersecurity alert.

Solutions for this threat 

Apache httpd: version 2.4.39.
The version 2.4.39 is fixed:
  https://httpd.apache.org/download.cgi

HP-UX Apache-based Web Server: version B.2.4.18.05.
The version B.2.4.18.05 is fixed:
  https://h20392.www2.hpe.com/portal/swdepot/displayProductInfo.do?productNumber=HPUXWSSUITE
  https://h20392.www2.hpe.com/portal/swdepot/displayProductInfo.do?productNumber=HPUXWSATW508

IBM i: patch for Apache httpd.
A patch is available:
  IBM i 7.2 - SI69901: https://www-945.ibm.com/support/fixcentral/
  IBM i 7.3 - SI69900 and SI69828: https://www-945.ibm.com/support/fixcentral/

IBM i: patch for HTTP Server.
A patch is indicated in information sources.

openSUSE Leap 15.0: new apache2 packages.
New packages are available:
  openSUSE Leap 15.0: apache2 2.4.33-lp150.2.17.1

openSUSE Leap 42.3: new apache2 packages.
New packages are available:
  openSUSE Leap 42.3: apache2 2.4.23-49.1

Oracle Communications: CPU of April 2020.
A Critical Patch Update is available:
  https://support.oracle.com/rs?type=doc&id=2647690.1
  https://support.oracle.com/rs?type=doc&id=2654603.1
  https://support.oracle.com/rs?type=doc&id=2652618.1
  https://support.oracle.com/rs?type=doc&id=2653087.1
  https://support.oracle.com/rs?type=doc&id=2653688.1
  https://support.oracle.com/rs?type=doc&id=2652610.1
  https://support.oracle.com/rs?type=doc&id=2653279.1
  https://support.oracle.com/rs?type=doc&id=2652619.1
  https://support.oracle.com/rs?type=doc&id=2652621.1
  https://support.oracle.com/rs?type=doc&id=2652606.1
  https://support.oracle.com/rs?type=doc&id=2653691.1
  https://support.oracle.com/rs?type=doc&id=2653692.1
  https://support.oracle.com/rs?type=doc&id=2647687.1
  https://support.oracle.com/rs?type=doc&id=2652622.1

RHEL 8: new httpd-2.4 module.
The following module is updated:
  RHEL 8 Module: httpd:2.4

SUSE LE 12: new apache2 packages.
New packages are available:
  SUSE LE 12 RTM: apache2 2.4.10-14.36.1
  SUSE LE 12 SP1: apache2 2.4.16-20.24.1
  SUSE LE 12 SP2: apache2 2.4.23-29.40.1
  SUSE LE 12 SP3: apache2 2.4.23-29.40.1
  SUSE LE 12 SP4: apache2 2.4.23-29.40.1

SUSE LE 15: new apache2 packages.
New packages are available:
  SUSE LE 15 RTM: apache2 2.4.33-3.15.1

Ubuntu: new apache2 packages.
New packages are available:
  Ubuntu 19.04: apache2 2.4.38-2ubuntu2.3
  Ubuntu 18.04 LTS: apache2 2.4.29-1ubuntu4.11
  Ubuntu 16.04 LTS: apache2 2.4.18-2ubuntu3.13

Wind River Linux: version 10.18.44.9.
The version 10.18.44.9 is fixed:
  https://support2.windriver.com/
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides application vulnerability bulletins. Each administrator can customize the list of products for which he wants to receive vulnerability alerts.