The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of Apache httpd: out-of-bounds memory reading via mod_cache_socache

Synthesis of the vulnerability 

An attacker can force a read at an invalid address via mod_cache_socache of Apache httpd, in order to trigger a denial of service, or to obtain sensitive information.
Impacted software: Apache httpd, Apache httpd Modules ~ not comprehensive, Blue Coat CAS, Broadcom Content Analysis, Debian, Fedora, openSUSE Leap, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Severity of this computer vulnerability: 2/4.
Creation date: 26/03/2018.
Références of this announce: CVE-2018-1303, DSA-4164-1, FEDORA-2018-375e3244b6, openSUSE-SU-2018:1198-1, RHSA-2018:3558-01, RHSA-2020:3958-01, SUSE-SU-2018:0879-1, SUSE-SU-2018:0901-1, SYMSA1457, USN-3627-1, USN-3627-2, VIGILANCE-VUL-25636.

Description of the vulnerability 

An attacker can force a read at an invalid address via mod_cache_socache of Apache httpd, in order to trigger a denial of service, or to obtain sensitive information.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This weakness alert impacts software or systems such as Apache httpd, Apache httpd Modules ~ not comprehensive, Blue Coat CAS, Broadcom Content Analysis, Debian, Fedora, openSUSE Leap, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Our Vigil@nce team determined that the severity of this computer vulnerability note is medium.

The trust level is of type confirmed by the editor, with an origin of internet client.

An attacker with a expert ability can exploit this security bulletin.

Solutions for this threat 

Apache httpd: version 2.4.30.
The version 2.4.30 is fixed:
  http://httpd.apache.org/download.cgi

Debian 8/9: new apache2 packages.
New packages are available:
  Debian 8: apache2 2.4.10-10+deb8u12
  Debian 9: apache2 2.4.25-3+deb9u4

Fedora 27: new httpd packages.
New packages are available:
  Fedora 27: httpd 2.4.33-2.fc27

openSUSE Leap 42.3: new apache2 packages.
New packages are available:
  openSUSE Leap 42.3: apache2 2.4.23-22.1

RHEL 7.8: new httpd packages.
New packages are available:
  RHEL 7.0-7.8: httpd 2.4.6-95.el7

RHEL: new httpd24 packages.
New packages are available:
  RHEL 6: httpd24-curl 7.61.1-1.el6, httpd24-httpd 2.4.34-7.el6, httpd24-nghttp2 1.7.1-7.el6
  RHEL 7: httpd24-curl 7.61.1-1.el7, httpd24-httpd 2.4.34-7.el7, httpd24-nghttp2 1.7.1-7.el7

SUSE LE 12 RTM: new apache2 packages.
New packages are available:
  SUSE LE 12 RTM: apache2 2.4.10-14.31.1

SUSE LE 12 SP1: new apache2 packages.
New packages are available:
  SUSE LE 12 SP1: apache2 2.4.16-20.16.1

Symantec Content and Malware Analysis: solution for Apache HTTP Server.
The solution is indicated in information sources.

Ubuntu: new apache2-bin packages.
New packages are available:
  Ubuntu 18.04 LTS: apache2-bin 2.4.29-1ubuntu4.1
  Ubuntu 17.10: apache2-bin 2.4.27-2ubuntu4.1
  Ubuntu 16.04 LTS: apache2-bin 2.4.18-2ubuntu3.8
  Ubuntu 14.04 LTS: apache2-bin 2.4.7-1ubuntu4.20
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides a software vulnerabilities workaround. The Vigil@nce computer vulnerability tracking service alerts your teams of vulnerabilities or threats impacting your information system.