The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of Apache httpd: three vulnerabilities

Synthesis of the vulnerability 

An attacker can use several vulnerabilities of Apache httpd.
Vulnerable systems: Apache httpd, Mac OS X, Debian, BIG-IP Hardware, TMOS, Fedora, HP-UX, Junos Space, openSUSE Leap, RHEL, Slackware, SUSE Linux Enterprise Desktop, SLES, TrendMicro ServerProtect, Ubuntu.
Severity of this threat: 3/4.
Number of vulnerabilities in this bulletin: 3.
Creation date: 21/12/2016.
Revision date: 22/12/2016.
Références of this weakness: 1117414, APPLE-SA-2017-09-25-1, CVE-2016-0736, CVE-2016-2161, CVE-2016-8743, DLA-841-1, DLA-841-2, DSA-3796-1, DSA-3796-2, FEDORA-2016-8d9b62c784, FEDORA-2016-d22f50d985, HPESBUX03725, HT207615, HT208144, HT208221, JSA10838, K00373024, openSUSE-SU-2017:0897-1, openSUSE-SU-2017:0903-1, openSUSE-SU-2018:2856-1, RHSA-2017:0906-01, RHSA-2017:1721-01, SSA:2016-358-01, SUSE-SU-2018:2554-1, SUSE-SU-2018:2815-1, USN-3279-1, USN-3373-1, VIGILANCE-VUL-21434.

Description of the vulnerability 

Several vulnerabilities were announced in Apache httpd.

An attacker can tamper with encrypted session data, in order to get knowledge of the plain text value. [severity:1/4; CVE-2016-0736]

An attacker can trigger a fatal error in case of use of shared memory, in order to trigger a denial of service. [severity:2/4; CVE-2016-2161]

An attacker can make profit of syntax error recovery to tamper with HTTP responses headers and bodies. [severity:3/4; CVE-2016-8743]
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This weakness note impacts software or systems such as Apache httpd, Mac OS X, Debian, BIG-IP Hardware, TMOS, Fedora, HP-UX, Junos Space, openSUSE Leap, RHEL, Slackware, SUSE Linux Enterprise Desktop, SLES, TrendMicro ServerProtect, Ubuntu.

Our Vigil@nce team determined that the severity of this threat note is important.

The trust level is of type confirmed by the editor, with an origin of internet client.

This bulletin is about 3 vulnerabilities.

An attacker with a expert ability can exploit this computer weakness.

Solutions for this threat 

Apache httpd: version 2.4.25.
The version 2.4.25 is fixed:
  http://apache.mediamirrors.org//httpd/httpd-2.4.25.tar.bz2

Apache httpd: version 2.2.32.
The version 2.2.32 is fixed:
  http://httpd.apache.org/download.cgi

Apple macOS 10.12: version Security Update 2017-001.
The version Security Update 2017-001 is fixed:
  https://support.apple.com/

Apple macOS: version 10.13.
The version 10.13 is fixed:
  https://www.apple.com/support/downloads/

Apple macOS: version 10.13.1.
The version 10.13.1 is fixed:
  https://support.apple.com/

Apple MacOS X 10.11: version Security Update 2017-004.
The version Security Update 2017-004 is fixed:
  https://support.apple.com/

Apple Mac OS X: version 10.12.4.
The version 10.12.4 is fixed.

Debian: new apache2 packages.
New packages are available:
  Debian 7: apache2 2.2.22-13+deb7u11
  Debian 8: apache2 2.4.10-10+deb8u8

F5 BIG-IP: solution for Apache.
The solution is indicated in information sources.

Fedora: new httpd packages.
New packages are available:
  Fedora 24: httpd 2.4.25-1.fc24
  Fedora 25: httpd 2.4.25-1.fc25

HP-UX Apache: version 2.4.18.02.
The version 2.4.18.02 is fixed:
  https://h20392.www2.hpe.com/portal/swdepot/displayProductInfo.do?productNumber=HPUXWSATW503

Junos Space: fixed versions.
Fixed versions are indicated in information sources.

openSUSE Leap 42.3: new apache2 packages.
New packages are available:
  openSUSE Leap 42.3: apache2 2.4.23-28.1

openSUSE Leap: new apache2 packages.
New packages are available:
  openSUSE Leap 42.1: apache2 2.4.16-18.1
  openSUSE Leap 42.2: apache2 2.4.23-8.3.1

RHEL 6.9: new httpd packages.
New packages are available:
  RHEL 6: httpd 2.2.15-60.el6_9.4

RHEL 7.3: new httpd packages.
New packages are available:
  RHEL 7: httpd 2.4.6-45.el7_3.4

Slackware: new httpd packages.
New packages are available:
  Slackware 14.0: httpd 2.4.25-*-1_slack14.0
  Slackware 14.1: httpd 2.4.25-*-1_slack14.1
  Slackware 14.2: httpd 2.4.25-*-1_slack14.2

SUSE LE 12 SP1: new apache2 packages.
New packages are available:
  SUSE LE 12 SP1: apache2 2.4.16-20.19.1

SUSE LE 12 SP2/3: new apache2 packages.
New packages are available:
  SUSE LE 12 SP2: apache2 2.4.23-29.24.1
  SUSE LE 12 SP3: apache2 2.4.23-29.24.1

Trend Micro ServerProtect: version 3.0.1531.
The version 3.0.1531 is fixed:
  http://files.trendmicro.com/products/splx/product%20patch/splx_30_lx_en_criticalpatch1531.tar.gz

Ubuntu 12.04: new apache2.2-bin packages.
New packages are available:
  Ubuntu 12.04 ESM: apache2.2-bin 2.2.22-1ubuntu1.12

Ubuntu: new apache2-bin packages.
New packages are available:
  Ubuntu 16.10: apache2-bin 2.4.18-2ubuntu4.1
  Ubuntu 16.04 LTS: apache2-bin 2.4.18-2ubuntu3.2
  Ubuntu 14.04 LTS: apache2-bin 2.4.7-1ubuntu4.14
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides application vulnerability analysis. Each administrator can customize the list of products for which he wants to receive vulnerability alerts.