The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of Asterisk: two vulnerabilities

Synthesis of the vulnerability 

An authenticated attacker can use two vulnerabilities of Asterisk, in order to execute a shell command, or to bypass ACL.
Vulnerable software: Asterisk Open Source, Debian, Fedora.
Severity of this announce: 2/4.
Number of vulnerabilities in this bulletin: 2.
Creation date: 31/08/2012.
Références of this computer vulnerability: AST-2012-012, AST-2012-013, BID-55335, BID-55351, CERTA-2012-AVI-478, CVE-2012-2186, CVE-2012-4737, DSA-2550-1, DSA-2550-2, FEDORA-2012-13338, FEDORA-2012-13437, VIGILANCE-VUL-11911.

Description of the vulnerability 

Two vulnerabilities were announced in Asterisk.

An authenticated attacker can use the action AMI Originate with the application ExternalIVR, in order to execute a shell command. [severity:2/4; AST-2012-012, BID-55351, CVE-2012-2186]

An attacker, who is authenticated with ARA (Asterisk Realtime Architecture), can make an IAX2 call bypassing ACL rules. [severity:2/4; AST-2012-013, BID-55335, CVE-2012-4737]

An authenticated attacker can therefore use two vulnerabilities of Asterisk, in order to execute a shell command, or to bypass ACL.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This computer vulnerability note impacts software or systems such as Asterisk Open Source, Debian, Fedora.

Our Vigil@nce team determined that the severity of this computer vulnerability announce is medium.

The trust level is of type confirmed by the editor, with an origin of intranet client.

This bulletin is about 2 vulnerabilities.

An attacker with a expert ability can exploit this cybersecurity announce.

Solutions for this threat 

Asterisk: version 10.7.1.
The version 10.7.1 is corrected:
  http://www.asterisk.org/

Asterisk: version 1.8.15.1.
The version 1.8.15.1 is corrected:
  http://www.asterisk.org/

Debian: new asterisk packages.
New packages are available:
  asterisk 1:1.6.2.9-2+squeeze8

Fedora: new asterisk packages.
New packages are available:
  asterisk-1.8.15.1-1.fc16
  asterisk-10.7.1-2.fc17
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides an application vulnerability announce. The Vigil@nce vulnerability database contains several thousand vulnerabilities.