The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of Audio File: buffer overflow via Expand3To4Module-run

Synthesis of the vulnerability 

An attacker can generate a buffer overflow via Expand3To4Module::run() of Audio File, in order to trigger a denial of service, and possibly to run code.
Vulnerable products: Fedora, openSUSE Leap, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Severity of this weakness: 3/4.
Creation date: 18/10/2018.
Références of this bulletin: CVE-2018-17095, FEDORA-2018-3058a87e60, FEDORA-2018-41626fa774, FEDORA-2018-b967b5592e, openSUSE-SU-2018:3537-1, openSUSE-SU-2018:3694-1, RHSA-2020:3877-01, SUSE-SU-2018:3506-1, SUSE-SU-2018:3588-1, SUSE-SU-2018:3588-2, USN-3800-1, VIGILANCE-VUL-27576.

Description of the vulnerability 

An attacker can generate a buffer overflow via Expand3To4Module::run() of Audio File, in order to trigger a denial of service, and possibly to run code.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This computer threat impacts software or systems such as Fedora, openSUSE Leap, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Our Vigil@nce team determined that the severity of this computer vulnerability alert is important.

The trust level is of type confirmed by the editor, with an origin of document.

An attacker with a expert ability can exploit this cybersecurity weakness.

Solutions for this threat 

Fedora: new audiofile packages.
New packages are available:
  Fedora 27: audiofile 0.3.6-21.fc27
  Fedora 28: audiofile 0.3.6-21.fc28
  Fedora 29: audiofile 0.3.6-21.fc29

openSUSE Leap 15.0: new audiofile packages.
New packages are available:
  openSUSE Leap 15.0: audiofile 0.3.6-lp150.2.3.1

openSUSE Leap 42.3: new audiofile packages.
New packages are available:
  openSUSE Leap 42.3: audiofile 0.3.6-13.3.1

RHEL 7.8: new audiofile packages.
New packages are available:
  RHEL 7.0-7.8: audiofile 0.3.6-9.el7

SUSE LE 12 SP3: new audiofile packages.
New packages are available:
  SUSE LE 12 SP3: audiofile 0.3.6-11.3.1

SUSE LE 12 SP4: new audiofile packages.
New packages are available:
  SUSE LE 12 SP4: audiofile 0.3.6-11.3.1

SUSE LE 15: new audiofile packages.
New packages are available:
  SUSE LE 15 RTM: audiofile 0.3.6-3.3.1

Ubuntu 14.04: new audiofile packages.
New packages are available:
  Ubuntu 14.04 LTS: audiofile-tools 0.3.6-2ubuntu0.14.04.3
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides software vulnerabilities announces. Each administrator can customize the list of products for which he wants to receive vulnerability alerts.