The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of BGP: denial of service via AS4_PATH

Synthesis of the vulnerability 

An attacker can use the AS4_PATH attribute in order to stop sessions of bgpd daemons.
Vulnerable software: Juniper E-Series, JUNOSe, OpenBSD, BGP protocol.
Severity of this announce: 2/4.
Creation date: 02/02/2009.
Références of this computer vulnerability: BID-33553, CQ 88706, PSN-2008-12-130, VIGILANCE-VUL-8437.

Description of the vulnerability 

The RFC 4893 extents the BGP protocol to support ASN (Autonomous System Number) on 4 bytes, instead of 2 bytes. The AS4_PATH and AS4_AGGREGATOR attributes can contain ASN on 4 bytes.

An AS Confederation (RFC 3065) is a collection of AS identified with only one ASN.

According to the RFC 4893, the AS4_PATH attribute must not contain a confederation path. The RFC does not clearly indicate how to handle this error case. Some bgpd daemons close the session.

Morever, an UPDATE message with a malicious AS4_PATH attribute can go through several routers not supporting AS4_PATH before being received on a router implementing the RFC.

An attacker can therefore send a UPDATE message with a malicious AS4_PATH attribute in order to create a denial of service on remote routers.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This computer weakness note impacts software or systems such as Juniper E-Series, JUNOSe, OpenBSD, BGP protocol.

Our Vigil@nce team determined that the severity of this security bulletin is medium.

The trust level is of type confirmed by the editor, with an origin of internet client.

An attacker with a expert ability can exploit this weakness announce.

Solutions for this threat 

OpenBSD: patch for bgpd.
A patch is available:
  ftp://ftp.openbsd.org/pub/OpenBSD/patches/4.3/common/009_bgpd.patch
  ftp://ftp.openbsd.org/pub/OpenBSD/patches/4.4/common/009_bgpd.patch

JUNOSe: version 8.1.4p0-4, 8.2.4p0-7, 9.0.2p0-1, 9.1.2p0-1, 9.2.1p0-1, 9.3.0p0-1, 10.0.0.
Versions 8.1.4p0-4, 8.2.4p0-7, 9.0.2p0-1, 9.1.2p0-1, 9.2.1p0-1, 9.3.0p0-1 and 10.0.0 are corrected.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides a network vulnerability watch. The Vigil@nce computer vulnerability tracking service alerts your teams of vulnerabilities or threats impacting your information system.