The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of CUPS: buffer overflow via SNMP

Synthesis of the vulnerability 

An attacker can trigger a buffer overflow via SNMP of CUPS, in order to trigger a denial of service, and possibly to run code.
Vulnerable systems: CUPS, Debian, openSUSE Leap, Solaris, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Severity of this threat: 2/4.
Number of vulnerabilities in this bulletin: 2.
Creation date: 19/08/2019.
Références of this weakness: CVE-2019-8675, CVE-2019-8696, DLA-1893-1, openSUSE-SU-2019:2573-1, openSUSE-SU-2019:2575-1, RHSA-2020:1765-01, SUSE-SU-2019:14229-1, SUSE-SU-2019:3030-1, SUSE-SU-2019:3057-1, USN-4105-1, VIGILANCE-VUL-30086.

Description of the vulnerability 

An attacker can trigger a buffer overflow via SNMP of CUPS, in order to trigger a denial of service, and possibly to run code.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This computer vulnerability announce impacts software or systems such as CUPS, Debian, openSUSE Leap, Solaris, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Our Vigil@nce team determined that the severity of this cybersecurity bulletin is medium.

The trust level is of type confirmed by the editor, with an origin of intranet client.

This bulletin is about 2 vulnerabilities.

An attacker with a expert ability can exploit this threat alert.

Solutions for this threat 

CUPS: version 2.2.12.
The version 2.2.12 is fixed:
  https://github.com/apple/cups/releases/tag/v2.2.12

Debian 8: new cups packages.
New packages are available:
  Debian 8: cups 1.7.5-11+deb8u5

openSUSE Leap 15.0: new cups packages.
New packages are available:
  openSUSE Leap 15.0: cups 2.2.7-lp150.2.13.1

openSUSE Leap 15.1: new cups packages.
New packages are available:
  openSUSE Leap 15.1: cups 2.2.7-lp151.6.3.1

Oracle Solaris: patch for third party software of April 2020 v2.
A patch is available:
  https://support.oracle.com/rs?type=doc&id=1448883.1

RHEL 8: new cups packages.
New packages are available:
  RHEL 8.0-8.1: cups 2.2.6-33.el8

SUSE LE 11: new cups packages.
New packages are available:
  SUSE LE 11 SP3: cups 1.3.9-8.46.56.8.1
  SUSE LE 11 SP4: cups 1.3.9-8.46.56.8.1

SUSE LE 12: new cups packages.
New packages are available:
  SUSE LE 12 SP1: cups 1.7.5-20.26.1
  SUSE LE 12 SP2: cups 1.7.5-20.26.1
  SUSE LE 12 SP3: cups 1.7.5-20.26.1
  SUSE LE 12 SP4: cups 1.7.5-20.26.1
  SUSE LE 12 SP5: cups 1.7.5-20.26.1

SUSE LE 15: new cups packages.
New packages are available:
  SUSE LE 15 RTM: cups 2.2.7-3.14.1
  SUSE LE 15 SP1: cups 2.2.7-3.14.1

Ubuntu: new cups packages.
New packages are available:
  Ubuntu 19.04: cups 2.2.10-4ubuntu2.1
  Ubuntu 18.04 LTS: cups 2.2.7-1ubuntu2.7
  Ubuntu 16.04 LTS: cups 2.1.3-4ubuntu0.10
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides computer vulnerability patches. The Vigil@nce team tracks computer vulnerabilities impacting systems and applications.