The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of CUPS: privilege escalation via Predictable Linux Session Cookies

Synthesis of the vulnerability 

An attacker can bypass restrictions via Predictable Linux Session Cookies of CUPS, in order to escalate his privileges.
Impacted systems: CUPS, Debian, openSUSE Leap, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Severity of this alert: 3/4.
Number of vulnerabilities in this bulletin: 2.
Creation date: 10/12/2018.
Références of this alert: 1706, CVE-2018-4300, CVE-2018-4700-REJECT, DLA-1936-1, openSUSE-SU-2018:4105-1, openSUSE-SU-2018:4141-1, RHSA-2020:1050-01, SUSE-SU-2018:4059-1, SUSE-SU-2018:4089-1, USN-3842-1, VIGILANCE-VUL-27989.

Description of the vulnerability 

An attacker can bypass restrictions via Predictable Linux Session Cookies of CUPS, in order to escalate his privileges.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This computer threat announce impacts software or systems such as CUPS, Debian, openSUSE Leap, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Our Vigil@nce team determined that the severity of this computer vulnerability is important.

The trust level is of type confirmed by the editor, with an origin of intranet client.

This bulletin is about 2 vulnerabilities.

An attacker with a expert ability can exploit this cybersecurity alert.

Solutions for this threat 

CUPS: version 2.2.10.
The version 2.2.10 is fixed:
  https://github.com/apple/cups/releases/tag/v2.2.10

Debian 8: new cups packages.
New packages are available:
  Debian 8: cups 1.7.5-11+deb8u6

openSUSE Leap 15.0: new cups packages.
New packages are available:
  openSUSE Leap 15.0: cups 2.2.7-lp150.2.6.1

openSUSE Leap 42.3: new cups packages.
New packages are available:
  openSUSE Leap 42.3: cups 1.7.5-12.9.1

RHEL 7: new cups packages.
New packages are available:
  RHEL 7.0-7.7: cups 1.6.3-43.el7

SUSE LE 12 SP3/4: new cups packages.
New packages are available:
  SUSE LE 12 SP3: cups 1.7.5-20.20.1
  SUSE LE 12 SP4: cups 1.7.5-20.20.1

SUSE LE 15: new cups packages.
New packages are available:
  SUSE LE 15 RTM: cups 2.2.7-3.6.1

Ubuntu: new cups packages.
New packages are available:
  Ubuntu 18.10: cups 2.2.8-5ubuntu1.1
  Ubuntu 18.04 LTS: cups 2.2.7-1ubuntu2.2
  Ubuntu 16.04 LTS: cups 2.1.3-4ubuntu0.6
  Ubuntu 14.04 LTS: cups 1.7.2-0ubuntu1.11
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides a computer security note. The Vigil@nce security watch publishes vulnerability bulletins about threats impacting the information system.