The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of D-Bus: sending a message

Synthesis of the vulnerability 

The default D-Bus policy allows an application to send a message.
Impacted systems: Fedora, openSUSE, SLES, Unix (platform) ~ not comprehensive.
Severity of this alert: 2/4.
Creation date: 08/12/2008.
Références of this alert: BID-32674, CVE-2008-4311, FEDORA-2008-10733, FEDORA-2008-10907, openSUSE-SU-2012:1418-1, SUSE-SA:2009:013, SUSE-SR:2009:008, SUSE-SR:2009:009, VIGILANCE-VUL-8291.

Description of the vulnerability 

The D-Bus environment is used by applications to exchange information.

Due to a logic error, the default policy of D-Bus allows applications to send and receive messages. If there is no explicit "deny" rule, messages are allowed.

A malicious application can therefore send messages to other applications, if there is no filtering rule to forbid it.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This vulnerability announce impacts software or systems such as Fedora, openSUSE, SLES, Unix (platform) ~ not comprehensive.

Our Vigil@nce team determined that the severity of this cybersecurity threat is medium.

The trust level is of type confirmed by the editor, with an origin of user shell.

An attacker with a expert ability can exploit this computer threat bulletin.

Solutions for this threat 

D-Bus: version 1.2.6.
Version 1.2.6 is corrected:
  http://dbus.freedesktop.org/dbus/releases/dbus-1.2.6.tar.gz

Fedora: new dbus packages.
New packages are available:
  dbus-1.2.6-1.fc9
  dbus-1.2.6-1.fc10

openSUSE 11/12: new dbus-1 packages.
New packages are available:
  openSUSE 11.4 : dbus-1-1.4.1-7.31.1
  openSUSE 12.1 : dbus-1-1.5.8-2.10.1
  openSUSE 12.2 : dbus-1-1.5.12-4.10.1

SUSE: new cumulative packages.
New packages are available.

SUSE: new dbus-1 packages.
New packages are available:
  openSUSE 11.1: dbus-1-1.2.10-5.3.1
  openSUSE 11.0: dbus-1-1.2.1-15.4
  openSUSE 10.3: dbus-1-1.0.2-59.8

SUSE: new multipath-tools, bluez, xntp, apache-mod_php4, apache2-mod_php5, struts, qemu, libsndfile, phpMyAdmin packages.
New packages are available.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides a software vulnerabilities announce. The Vigil@nce computer vulnerability tracking service alerts your teams of vulnerabilities or threats impacting your information system.