The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a database and tools to fix them.

Vulnerability of DBus: privilege escalation via DBUS_COOKIE_SHA1

Synthesis of the vulnerability

An attacker can bypass restrictions via DBUS_COOKIE_SHA1 of DBus, in order to escalate his privileges.
Severity of this announce: 2/4.
Creation date: 12/06/2019.
Références of this computer vulnerability: CVE-2019-12749, DLA-1818-1, DSA-4462-1, FEDORA-2019-d5ded5326b, openSUSE-SU-2019:1604-1, openSUSE-SU-2019:1671-1, openSUSE-SU-2019:1750-1, RHSA-2019:1726-01, RHSA-2019:2868-01, RHSA-2019:2870-01, RHSA-2019:3707-01, SUSE-SU-2019:14111-1, SUSE-SU-2019:1521-1, SUSE-SU-2019:1591-1, SUSE-SU-2019:1595-1, SUSE-SU-2019:1597-1, SUSE-SU-2019:2820-1, USN-4015-1, USN-4015-2, VIGILANCE-VUL-29515.

Description of the vulnerability

An attacker can bypass restrictions via DBUS_COOKIE_SHA1 of DBus, in order to escalate his privileges.
Full Vigil@nce bulletin... (Free trial)

This computer vulnerability alert impacts software or systems such as Debian, Fedora, openSUSE Leap, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Our Vigil@nce team determined that the severity of this computer threat alert is medium.

The trust level is of type confirmed by the editor, with an origin of user shell.

An attacker with a expert ability can exploit this security vulnerability.

Solutions for this threat

Debian 8: new dbus packages.
New packages are available:
  Debian 8: dbus 1.8.22-0+deb8u2

Debian 9: new dbus packages.
New packages are available:
  Debian 9: dbus 1.10.28-0+deb9u1

Fedora 30: new dbus packages.
New packages are available:
  Fedora 30: dbus 1.12.16-1.fc30

openSUSE Leap 15.0: new dbus-1 packages (01/07/2019).
New packages are available:
  openSUSE Leap 15.0: dbus-1 1.12.2-lp150.2.4.2

openSUSE Leap 15.0: new dbus-1 packages (25/06/2019).
New packages are available:
  openSUSE Leap 15.0: dbus-1 1.12.2-lp150.2.3.1

openSUSE Leap 15.1: new dbus-1 packages.
New packages are available:
  openSUSE Leap 15.1: dbus-1 1.12.2-lp151.4.3.1

RHEL 6.10: new dbus packages.
New packages are available:
  RHEL 6: dbus 1.2.24-11.el6_10
  RHEL 6.6: dbus 1.2.24-9.el6_6
  RHEL 6.5: dbus 1.2.24-9.el6_5

RHEL 8: new dbus packages.
New packages are available:
  RHEL 8: dbus 1.12.8-9.el8

SUSE LE 11: new dbus-1 packages.
New packages are available:
  SUSE LE 11 SP3: dbus-1 1.2.10-3.34.8.1
  SUSE LE 11 SP4: dbus-1 1.2.10-3.34.8.1

SUSE LE 12: new dbus-1 packages.
New packages are available:
  SUSE LE 12 RTM: dbus-1 1.8.22-24.19.1
  SUSE LE 12 SP1: dbus-1 1.8.22-24.19.1
  SUSE LE 12 SP2: dbus-1 1.8.22-24.19.1

SUSE LE 12 SP3/4: new dbus-1 packages.
New packages are available:
  SUSE LE 12 SP3: dbus-1 1.8.22-29.17.12
  SUSE LE 12 SP4: dbus-1 1.8.22-29.17.12

SUSE LE 15 RTM: new dbus-1 packages (18/06/2019).
New packages are available:
  SUSE LE 15 RTM: dbus-1 1.12.2-3.5.1

SUSE LE 15 RTM: new dbus-1 packages (21/06/2019).
New packages are available:
  SUSE LE 15 RTM: dbus-1 1.12.2-3.8.1

SUSE LE 15 SP1: new dbus-1 packages.
New packages are available:
  SUSE LE 15 SP1: dbus-1 1.12.2-8.3.1

Ubuntu: new dbus packages.
New packages are available:
  Ubuntu 19.04: dbus 1.12.12-1ubuntu1.1
  Ubuntu 18.10: dbus 1.12.10-1ubuntu2.1
  Ubuntu 18.04 LTS: dbus 1.12.2-1ubuntu1.1
  Ubuntu 16.04 LTS: dbus 1.10.6-1ubuntu3.4
  Ubuntu 14.04 ESM: dbus 1.6.18-0ubuntu4.5+esm1
  Ubuntu 12.04 ESM: dbus 1.4.18-1ubuntu1.9
Full Vigil@nce bulletin... (Free trial)

Computer vulnerabilities tracking service

Vigil@nce provides a networks vulnerabilities watch. The Vigil@nce security watch publishes vulnerability bulletins about threats impacting the information system.