The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of DNS: vulnerabilities of some implementations

Synthesis of the vulnerability 

Several implementations of DNS protocol are affected by the same vulnerabilities.
Vulnerable products: Arkoon FAST360, Juniper E-Series, JUNOSe, DNS protocol, Unix (platform) ~ not comprehensive.
Severity of this weakness: 1/4.
Number of vulnerabilities in this bulletin: 5.
Creation date: 25/04/2006.
Références of this bulletin: 144154, 144154/NISCC/DNS, 31AK-2006-02-FR-1.0_FAST_DNS_DOS, BID-17691, BID-17692, BID-17693, BID-17694, CQ 72492, CVE-2006-2072, CVE-2006-2073, CVE-2006-2074, CVE-2006-2075, CVE-2006-7054, PSN-2006-04-017, VIGILANCE-VUL-5796, VU#955777.

Description of the vulnerability 

The DNS protocol is used to associate an IP address to a name, or to obtain MTA mail servers of a domain.

The OUSPG group of Oulu University (Finland) published a test suite named PROTOS DNS. This test suite contains several thousand malformed DNS packets.

When some products receive these packets, errors occur (buffer overflow or denial of service).

Depending on products, these vulnerabilities lead to code execution or to a denial of service.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This computer threat impacts software or systems such as Arkoon FAST360, Juniper E-Series, JUNOSe, DNS protocol, Unix (platform) ~ not comprehensive.

Our Vigil@nce team determined that the severity of this computer vulnerability alert is low.

The trust level is of type confirmed by the editor, with an origin of internet client.

This bulletin is about 5 vulnerabilities.

An attacker with a expert ability can exploit this cybersecurity weakness.

Solutions for this threat 

DeleGate: versions 8.11.6 and 9.0.6.
Versions 8.11.6 and 9.0.6 are corrected:
  http://www.delegate.org/delegate/

MyDNS: version 1.1.0.
Version 1.1.0 is corrected:
  http://mydns.bboy.net/download/

pdnsd: version 1.2.4.
Version 1.2.4 is corrected:
  http://www.phys.uu.nl/~rombouts/pdnsd.html

Arkoon: versions 3.0/30 and 4.0/2.
Versions 3.0/30 et 4.0/2 are corrected.

JUNOSe: versions 5-3-5p0-2, 6-0-3p0-6, 6-0-4, 6-1-3p0-1, 7-0-1p0-7, 7-0-2, 7-1-0p0-1, 7-1-1.
Versions 5-3-5p0-2, 6-0-3p0-6, 6-0-4, 6-1-3p0-1, 7-0-1p0-7, 7-0-2, 7-1-0p0-1, 7-1-1 and superiors are corrected.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides a computer security workaround. Each administrator can customize the list of products for which he wants to receive vulnerability alerts.