The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of Docker Engine/Moby: denial of service via Image Pull

Synthesis of the vulnerability 

An attacker can trigger a fatal error via Image Pull of Docker Engine/Moby, in order to trigger a denial of service.
Impacted software: Debian, Docker CE, IBM API Connect, openSUSE Leap, SUSE Linux Enterprise Desktop, SLES.
Severity of this computer vulnerability: 1/4.
Creation date: 02/02/2021.
Références of this announce: 6427671, CVE-2021-21285, DSA-4865-1, GHSA-6fj5-m822-rqx8, openSUSE-SU-2021:0278-1, openSUSE-SU-2021:0878-1, SUSE-SU-2021:0435-1, SUSE-SU-2021:0445-1, SUSE-SU-2021:1954-1, VIGILANCE-VUL-34456.

Description of the vulnerability 

An attacker can trigger a fatal error via Image Pull of Docker Engine/Moby, in order to trigger a denial of service.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This vulnerability bulletin impacts software or systems such as Debian, Docker CE, IBM API Connect, openSUSE Leap, SUSE Linux Enterprise Desktop, SLES.

Our Vigil@nce team determined that the severity of this security note is low.

The trust level is of type confirmed by the editor, with an origin of document.

An attacker with a expert ability can exploit this cybersecurity note.

Solutions for this threat 

Docker Engine/Moby: version 20.10.3.
The version 20.10.3 is fixed:
  https://github.com/moby/moby

Docker Engine/Moby: version 19.03.15.
The version 19.03.15 is fixed:
  https://github.com/moby/moby

Debian 10: new docker.io packages.
New packages are available:
  Debian 10: docker.io 18.09.1+dfsg1-7.1+deb10u3

IBM API Connect: fixed versions for Docker.
Fixed versions are indicated in information sources.

openSUSE Leap 15.2: new containerd packages (12/02/2021).
New packages are available:
  openSUSE Leap 15.2: containerd 1.3.9-lp152.2.3.1, docker 19.03.15_ce-lp152.2.3.1

openSUSE Leap 15.2: new containerd packages (16/06/2021).
New packages are available:
  openSUSE Leap 15.2: containerd 1.4.4-lp152.2.6.1, docker 20.10.6_ce-lp152.2.12.1, runc 1.0.0~rc93-lp152.2.3.1

SUSE LE 12: new containerd packages.
New packages are available:
  SUSE LE 12 RTM-SP5: containerd 1.3.9-16.35.1, docker 19.03.15_ce-98.60.2

SUSE LE 15 RTM-SP3: new containerd packages.
New packages are available:
  SUSE LE 15 RTM: containerd 1.4.4-5.32.1, docker 20.10.6_ce-6.49.3
  SUSE LE 15 SP1: containerd 1.4.4-5.32.1, docker 20.10.6_ce-6.49.3, runc 1.0.0~rc93-1.14.2
  SUSE LE 15 SP2: containerd 1.4.4-5.32.1, docker 20.10.6_ce-6.49.3, runc 1.0.0~rc93-1.14.2
  SUSE LE 15 SP3: containerd 1.4.4-5.32.1, docker 20.10.6_ce-6.49.3, runc 1.0.0~rc93-1.14.2

SUSE LE 15 SP1-3: new containerd packages.
New packages are available:
  SUSE LE 15 SP1: containerd 1.3.9-5.29.3, docker 19.03.15_ce-6.43.3
  SUSE LE 15 SP2: containerd 1.3.9-5.29.3, docker 19.03.15_ce-6.43.3
  SUSE LE 15 SP3: containerd 1.3.9-5.29.3, docker 19.03.15_ce-6.43.3
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides a computers vulnerabilities database. The Vigil@nce vulnerability database contains several thousand vulnerabilities.