The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of Dovecot IMAP server: out-of-bounds memory reading via NTLM Package

Synthesis of the vulnerability 

An attacker can force a read at an invalid address via NTLM Package of Dovecot IMAP server, in order to trigger a denial of service, or to obtain sensitive information.
Impacted systems: Debian, Fedora, openSUSE Leap, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Severity of this alert: 2/4.
Creation date: 12/08/2020.
Références of this alert: CVE-2020-12673, DLA-2328-1, DSA-4745-1, FEDORA-2020-cd8b8f887b, FEDORA-2020-d737c57172, openSUSE-SU-2020:1241-1, openSUSE-SU-2020:1262-1, RHSA-2020:3617-01, RHSA-2020:3713-01, RHSA-2020:3735-01, RHSA-2020:3736-01, SUSE-SU-2020:2266-1, SUSE-SU-2020:2267-1, SUSE-SU-2020:2274-1, USN-4456-1, USN-4456-2, VIGILANCE-VUL-33065.

Description of the vulnerability 

An attacker can force a read at an invalid address via NTLM Package of Dovecot IMAP server, in order to trigger a denial of service, or to obtain sensitive information.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This security weakness impacts software or systems such as Debian, Fedora, openSUSE Leap, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Our Vigil@nce team determined that the severity of this threat bulletin is medium.

The trust level is of type confirmed by the editor, with an origin of intranet client.

An attacker with a expert ability can exploit this threat.

Solutions for this threat 

Debian 10: new dovecot packages.
New packages are available:
  Debian 10: dovecot 1:2.3.4.1-5+deb10u3

Debian 9: new dovecot packages.
New packages are available:
  Debian 9: dovecot 1:2.2.27-3+deb9u6

Fedora 31: new dovecot packages.
New packages are available:
  Fedora 31: dovecot 2.3.11.3-4.fc31

Fedora 32: new dovecot packages.
New packages are available:
  Fedora 32: dovecot 2.3.11.3-5.fc32

openSUSE Leap 15.1: new dovecot23 packages.
New packages are available:
  openSUSE Leap 15.1: dovecot23 2.3.10-lp151.2.12.1

openSUSE Leap 15.2: new dovecot23 packages.
New packages are available:
  openSUSE Leap 15.2: dovecot23 2.3.10-lp152.2.3.1

RHEL 7.8: new dovecot packages.
New packages are available:
  RHEL 7.8: dovecot 2.2.36-6.el7_8.1

RHEL 8.0: new dovecot packages.
New packages are available:
  RHEL 8.0: dovecot 2.2.36-5.el8_0.3

RHEL 8.1: new dovecot packages.
New packages are available:
  RHEL 8.1: dovecot 2.2.36-10.el8_1.2

RHEL 8.2: new dovecot packages.
New packages are available:
  RHEL 8.2: dovecot 2.3.8-2.el8_2.2

SUSE LE 12: new dovecot22 packages.
New packages are available:
  SUSE LE 12 SP2: dovecot22 2.2.31-19.22.1
  SUSE LE 12 SP3: dovecot22 2.2.31-19.22.1
  SUSE LE 12 SP4: dovecot22 2.2.31-19.22.1
  SUSE LE 12 SP5: dovecot22 2.2.31-19.22.1

SUSE LE 15 RTM-SP1: new dovecot23 packages.
New packages are available:
  SUSE LE 15 RTM: dovecot23 2.3.10-4.27.1
  SUSE LE 15 SP1: dovecot23 2.3.10-16.1

Ubuntu: new dovecot-core packages.
New packages are available:
  Ubuntu 20.04 LTS: dovecot-core 1:2.3.7.2-1ubuntu3.2
  Ubuntu 18.04 LTS: dovecot-core 1:2.2.33.2-1ubuntu4.6
  Ubuntu 16.04 LTS: dovecot-core 1:2.2.22-1ubuntu2.13
  Ubuntu 14.04 ESM: dovecot-core 1:2.2.9-1ubuntu2.6+esm3
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides system vulnerability analysis. Each administrator can customize the list of products for which he wants to receive vulnerability alerts.