The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of Drupal Password Policy: bypassing the policy

Synthesis of the vulnerability 

An attacker can continue to use the same password with Drupal Password Policy, in order to bypass the security policy.
Vulnerable systems: Drupal Modules ~ not comprehensive.
Severity of this threat: 1/4.
Creation date: 22/05/2014.
Références of this weakness: DRUPAL-SA-CONTRIB-2014-057, VIGILANCE-VUL-14786.

Description of the vulnerability 

The Password Policy module can be installed on Drupal.

However, unlike expressed by the policy, a user can choose several times the same password.

An attacker can therefore continue to use the same password with Drupal Password Policy, in order to bypass the security policy.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This computer weakness bulletin impacts software or systems such as Drupal Modules ~ not comprehensive.

Our Vigil@nce team determined that the severity of this computer threat announce is low.

The trust level is of type confirmed by the editor, with an origin of user account.

An attacker with a expert ability can exploit this threat announce.

Solutions for this threat 

Drupal Password Policy: version 7.x-1.6.
The version 7.x-1.6 is fixed:
  http://drupal.org/project/password_policy
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides a network vulnerability patch. Each administrator can customize the list of products for which he wants to receive vulnerability alerts.