The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a database and tools to fix them.

Vulnerability of ECDSA/EdDSA: information disclosure via Side-channel Key Recovery

Synthesis of the vulnerability

An attacker can bypass access restrictions to data via Side-channel Key Recovery of ECDSA/EdDSA, in order to obtain sensitive information. This vulnerability is the origin of VIGILANCE-VUL-30098, VIGILANCE-VUL-30205 and VIGILANCE-VUL-30534.
Severity of this threat: 2/4.
Number of vulnerabilities in this bulletin: 4.
Creation date: 04/10/2019.
Références of this weakness: cpuoct2019, CVE-2019-13628, CVE-2019-13629, CVE-2019-15809, CVE-2019-2894, DLA-2023-1, DSA-2019-168, DSA-2019-169, DSA-4546-1, DSA-4548-1, Minerva, NTAP-20191017-0001, openSUSE-SU-2019:2557-1, openSUSE-SU-2019:2565-1, SUSE-SU-2019:2998-1, SUSE-SU-2019:3083-1, SUSE-SU-2019:3084-1, SUSE-SU-2019:3238-1, VIGILANCE-VUL-30530.

Description of the vulnerability

An attacker can bypass access restrictions to data via Side-channel Key Recovery of ECDSA/EdDSA, in order to obtain sensitive information. This vulnerability is the origin of VIGILANCE-VUL-30098, VIGILANCE-VUL-30205 and VIGILANCE-VUL-30534.
Full Vigil@nce bulletin... (Free trial)

This computer threat alert impacts software or systems such as Debian, SnapManager, Java OpenJDK, openSUSE Leap, Java Oracle, RSA Authentication Manager, SafeNet eToken, SUSE Linux Enterprise Desktop, SLES.

Our Vigil@nce team determined that the severity of this weakness announce is medium.

The trust level is of type confirmed by the editor, with an origin of user shell.

This bulletin is about 4 vulnerabilities.

An attacker with a expert ability can exploit this computer weakness bulletin.

Solutions for this threat

Debian 10: new openjdk-11 packages.
New packages are available:
  Debian 10: openjdk-11 11_11.0.5+10-1~deb10u1

Debian 8: new openjdk-7 packages.
New packages are available:
  Debian 8: openjdk-7 7u241-2.6.20-1~deb8u1

Debian 9: new openjdk-8 packages.
New packages are available:
  Debian 9: openjdk-8 8u232-b09-1~deb9u1

OpenJDK: versions 7u241, 8u232, 11.0.5 and 13.0.1.
Versions 7u241, 8u232, 11.0.5 and 13.0.1 are fixed:
  https://openjdk.java.net/

openSUSE Leap 15: new java-11-openjdk packages.
New packages are available:
  openSUSE Leap 15.0: java-11-openjdk 11.0.5.0-lp150.2.28.1
  openSUSE Leap 15.1: java-11-openjdk 11.0.5.0-lp151.3.9.2

Oracle Java: version 11.0.5.
The version 11.0.5 is fixed:
  http://www.oracle.com/technetwork/indexes/downloads/index.html
  https://www.oracle.com/technetwork/java/javase/11u-relnotes-5093844.html

Oracle Java: version 13.0.1.
The version 13.0.1 is fixed:
  http://www.oracle.com/technetwork/indexes/downloads/index.html
  https://www.oracle.com/technetwork/java/javase/13u-relnotes-5461742.html

Oracle Java: version 7u241.
The version 7u241 is fixed:
  http://www.oracle.com/technetwork/indexes/downloads/index.html
  http://www.oracle.com/technetwork/java/javase/documentation/javase7supportreleasenotes-1601161.html

Oracle Java: version 8u231.
The version 8u231 is fixed:
  http://www.oracle.com/technetwork/indexes/downloads/index.html
  http://www.oracle.com/technetwork/java/javase/documentation/8u-relnotes-2225394.html

RSA Authentication Manager: version 8.4 P8.
The version 8.4 P8 is fixed:
  https://www.dell.com/

SnapManager: solution for Java.
The solution is indicated in information sources.

SUSE LE 12: new java-1_7_0-openjdk packages.
New packages are available:
  SUSE LE 12 SP1: java-1_7_0-openjdk 1.7.0.241-43.30.1
  SUSE LE 12 SP2: java-1_7_0-openjdk 1.7.0.241-43.30.1
  SUSE LE 12 SP3: java-1_7_0-openjdk 1.7.0.241-43.30.1
  SUSE LE 12 SP4: java-1_7_0-openjdk 1.7.0.241-43.30.1
  SUSE LE 12 SP5: java-1_7_0-openjdk 1.7.0.241-43.30.1

SUSE LE 12 SP5: new java-11-openjdk packages.
New packages are available:
  SUSE LE 12 SP5: java-11-openjdk 11.0.5.0-3.3.3

SUSE LE 15: new java-11-openjdk packages.
New packages are available:
  SUSE LE 15 RTM: java-11-openjdk 11.0.5.0-3.36.1
  SUSE LE 15 SP1: java-11-openjdk 11.0.5.0-3.36.1

SUSE LE 15: new java-1_8_0-openjdk packages.
New packages are available:
  SUSE LE 15 RTM: java-1_8_0-openjdk 1.8.0.232-3.27.1
  SUSE LE 15 SP1: java-1_8_0-openjdk 1.8.0.232-3.27.1
Full Vigil@nce bulletin... (Free trial)

Computer vulnerabilities tracking service

Vigil@nce provides application vulnerability alerts. The Vigil@nce computer vulnerability tracking service alerts your teams of vulnerabilities or threats impacting your information system.