The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of ESRI ArcGIS for Desktop: SQL injection

Synthesis of the vulnerability 

An attacker can use a SQL injection in ESRI ArcGIS for Desktop, in order to read or alter data.
Impacted products: ArcGIS for Desktop.
Severity of this bulletin: 1/4.
Creation date: 08/07/2013.
Références of this threat: VIGILANCE-VUL-13053.

Description of the vulnerability 

ESRI ArcGIS for Desktop is a tool for geographical map creation.

It can be used wuith a relational database. However, for some query, user's data are directly inserted into the WHERE part of a SQL query. Request technical details are unknown.

An attacker can therefore use a SQL injection in ESRI ArcGIS for Desktop, in order to read or alter data.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This threat impacts software or systems such as ArcGIS for Desktop.

Our Vigil@nce team determined that the severity of this computer threat is low.

The trust level is of type confirmed by the editor, with an origin of user shell.

An attacker with a expert ability can exploit this cybersecurity bulletin.

Solutions for this threat 

ESRI ArcGIS for Desktop: version 10.2.
The version 10.2 is fixed.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides a cybersecurity bulletin. The Vigil@nce vulnerability database contains several thousand vulnerabilities.