The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of Firefox 2.0: several vulnerabilities

Synthesis of the vulnerability 

Several vulnerabilities were announced in Firefox 2.0, the worst one leading to code execution.
Impacted software: Firefox, openSUSE, Slackware.
Severity of this computer vulnerability: 4/4.
Number of vulnerabilities in this bulletin: 8.
Creation date: 20/12/2006.
Références of this announce: BID-21668, CERTA-2006-AVI-568, CVE-2006-6497, CVE-2006-6498, CVE-2006-6499, CVE-2006-6500, CVE-2006-6501, CVE-2006-6502, CVE-2006-6503, CVE-2006-6504, CVE-2006-6506, CVE-2006-6507, MFSA2006-68, MFSA2006-69, MFSA2006-70, MFSA2006-71, MFSA2006-72, MFSA2006-73, MFSA2006-75, MFSA2006-76, SSA:2006-357-01, SUSE-SA:2006:080, VIGILANCE-VUL-6412, VU#263412, VU#405092, VU#427972, VU#428500, VU#447772, VU#606260, VU#722244, VU#928956, ZDI-06-051.

Description of the vulnerability 

Several vulnerabilities were announced in Firefox 2.0.

Several vulnerabilities of layout engine or of Javascript lead to memory corruptions, and to code execution. [severity:4/4; CERTA-2006-AVI-568, CVE-2006-6497, CVE-2006-6498, CVE-2006-6499, MFSA2006-68, VU#427972, VU#447772, VU#606260]

The "CSS cursor" property permits to corrupt memory in order to execute code. [severity:4/4; CVE-2006-6500, MFSA2006-69, VU#722244]

The JavaScript watch() function leads to code execution. [severity:4/4; CVE-2006-6501, MFSA2006-70, VU#263412]

A memory corruption of LiveConnect may lead to code execution. [severity:4/4; CVE-2006-6502, MFSA2006-71, VU#428500]

An attacker can execute script code via IMG and FRAME. [severity:4/4; CVE-2006-6503, MFSA2006-72, VU#405092]

An attacker can corrupt memory using a SVG comment. [severity:4/4; CVE-2006-6504, MFSA2006-73, VU#928956, ZDI-06-051]

When user subscribes to a RSS feed, a favicon is requested to Google, which permit them to know user's habits. [severity:4/4; CVE-2006-6506, MFSA2006-75]

An error of Function.prototype permits an attacker to inject script code. [severity:4/4; CVE-2006-6507, MFSA2006-76]
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This computer threat impacts software or systems such as Firefox, openSUSE, Slackware.

Our Vigil@nce team determined that the severity of this computer vulnerability alert is critical.

The trust level is of type confirmed by the editor, with an origin of internet server.

This bulletin is about 8 vulnerabilities.

An attacker with a expert ability can exploit this cybersecurity weakness.

Solutions for this threat 

Firefox: version 2.0.0.1.
Version 2.0.0.1 is corrected:
  http://www.getfirefox.com/

Slackware: new mozilla-firefox packages.
New packages are available:
Slackware 10.2:
ftp://ftp.slackware.com/pub/slackware/slackware-10.2/patches/packages/mozilla-firefox-1.5.0.9-i686-1.tgz
Slackware 11.0:
ftp://ftp.slackware.com/pub/slackware/slackware-11.0/extra/mozilla-firefox-2.0.0.1/mozilla-firefox-2.0.0.1-i686-1.tgz
ftp://ftp.slackware.com/pub/slackware/slackware-11.0/patches/packages/mozilla-firefox-1.5.0.9-i686-1.tgz

SUSE: new MozillaFirefox, MozillaThunderbird packages.
New packages are available:
   openSUSE 10.2:
   ftp://ftp.suse.com/pub/suse/update/10.2/rpm/i586/MozillaFirefox-2.0.0.1-0.1.i586.rpm
         eea9f40b409823d691ad0e1b3daf5a82
   ftp://ftp.suse.com/pub/suse/update/10.2/rpm/i586/MozillaFirefox-translations-2.0.0.1-0.1.i586.rpm
         dc5e760f067b2d1ea41be90c92517a5d
   ftp://ftp.suse.com/pub/suse/update/10.2/rpm/i586/MozillaThunderbird-1.5.0.9-0.1.i586.rpm
         0b3638d9bfccfca0cf149df1200e6c47
   ftp://ftp.suse.com/pub/suse/update/10.2/rpm/i586/MozillaThunderbird-translations-1.5.0.9-0.1.i586.rpm
         d51cb9ff1cb3f5875cb4fa60b58f159b
   SUSE LINUX 10.1:
   ftp://ftp.suse.com/pub/suse/update/10.1/rpm/i586/MozillaFirefox-1.5.0.9-0.2.i586.rpm
         fa3a6d10cb1a6dd801668e8881424036
   ftp://ftp.suse.com/pub/suse/update/10.1/rpm/i586/MozillaFirefox-translations-1.5.0.9-0.2.i586.rpm
         a40dc8d7e29aa8bb21ecb3c348e0cc05
   ftp://ftp.suse.com/pub/suse/update/10.1/rpm/i586/MozillaThunderbird-1.5.0.9-0.1.i586.rpm
         3bbfce9a8abf9394959348e449b35b95
   ftp://ftp.suse.com/pub/suse/update/10.1/rpm/i586/MozillaThunderbird-translations-1.5.0.9-0.1.i586.rpm
         869cac360c49cc15358b205923f2ee1d
   SUSE LINUX 10.0:
   ftp://ftp.suse.com/pub/suse/i386/update/10.0/rpm/i586/MozillaFirefox-1.5.0.9-0.1.i586.rpm
         f0b6bd1b56b874eb0003752cd112d6db
   ftp://ftp.suse.com/pub/suse/i386/update/10.0/rpm/i586/MozillaFirefox-translations-1.5.0.9-0.1.i586.rpm
         1722380cad796cc29d15374f7c471f09
   ftp://ftp.suse.com/pub/suse/i386/update/10.0/rpm/i586/MozillaThunderbird-1.5.0.9-0.1.i586.rpm
         82d7d8847f363a9e46fc9d22aa44f0c8
   SUSE LINUX 9.3:
   ftp://ftp.suse.com/pub/suse/i386/update/9.3/rpm/i586/MozillaFirefox-1.5.0.9-0.1.i586.rpm
         06b3af42ed8f528a306650691558301f
   ftp://ftp.suse.com/pub/suse/i386/update/9.3/rpm/i586/MozillaFirefox-translations-1.5.0.9-0.1.i586.rpm
         be42160ef33ead2625b20043267c2ce2
   ftp://ftp.suse.com/pub/suse/i386/update/9.3/rpm/i586/MozillaThunderbird-1.5.0.9-0.1.i586.rpm
         239aa22605bbd7c89a8489fb49c51f5d
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides applications vulnerabilities alerts. The Vigil@nce security watch publishes vulnerability bulletins about threats impacting the information system.