The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of FreeRDP: memory corruption

Synthesis of the vulnerability 

An attacker can trigger a memory corruption of FreeRDP, in order to trigger a denial of service, and possibly to run code.
Impacted products: openSUSE Leap, RHEL, SLES, Ubuntu.
Severity of this bulletin: 2/4.
Number of vulnerabilities in this bulletin: 14.
Creation date: 02/06/2020.
Références of this threat: CVE-2020-11042, CVE-2020-11044, CVE-2020-11045, CVE-2020-11046, CVE-2020-11047, CVE-2020-11048, CVE-2020-11049, CVE-2020-11058, CVE-2020-11522, CVE-2020-11525, CVE-2020-11526, CVE-2020-13396, CVE-2020-13397, CVE-2020-13398, openSUSE-SU-2020:1090-1, RHSA-2020:2405-01, RHSA-2020:2406-01, RHSA-2020:2407-01, RHSA-2020:2415-01, RHSA-2020:2417-01, SUSE-SU-2020:2032-1, SUSE-SU-2020:2068-1, USN-4379-1, USN-4382-1, VIGILANCE-VUL-32385.

Description of the vulnerability 

An attacker can trigger a memory corruption of FreeRDP, in order to trigger a denial of service, and possibly to run code.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This computer vulnerability bulletin impacts software or systems such as openSUSE Leap, RHEL, SLES, Ubuntu.

Our Vigil@nce team determined that the severity of this vulnerability bulletin is medium.

The trust level is of type confirmed by the editor, with an origin of internet server.

This bulletin is about 14 vulnerabilities.

An attacker with a expert ability can exploit this threat note.

Solutions for this threat 

openSUSE Leap 15.1: new freerdp packages.
New packages are available:
  openSUSE Leap 15.1: freerdp 2.1.2-lp151.5.6.1

RHEL 6.10: new freerdp packages.
New packages are available:
  RHEL 6.10: freerdp 1.0.2-7.el6_10

RHEL 7.8: new freerdp packages.
New packages are available:
  RHEL 7.8: freerdp 2.0.0-4.rc4.el7_8.1

RHEL 8: new freerdp packages.
New packages are available:
  RHEL 8.0: freerdp 2.0.0-46.rc4.el8_0.2
  RHEL 8.1: freerdp 2.0.0-46.rc4.el8_1.2
  RHEL 8.2: freerdp 2.0.0-46.rc4.el8_2.2

SUSE LE 15 SP1: new freerdp packages.
New packages are available:
  SUSE LE 15 SP1: freerdp 2.1.2-10.15.1

SUSE LE 15 SP2: new freerdp packages.
New packages are available:
  SUSE LE 15 SP2: freerdp 2.1.2-15.7.1

Ubuntu 16.04: new libfreerdp packages.
New packages are available:
  Ubuntu 16.04 LTS: libfreerdpb 1.1.0~git20140921.1.440916e+dfsg1-5ubuntu1.4

Ubuntu: new FreeRDP packages.
New packages are available:
  Ubuntu 20.04 LTS: libfreerdp-client2-2 2.1.1+dfsg1-0ubuntu0.20.04.1, libfreerdp-server2-2 2.1.1+dfsg1-0ubuntu0.20.04.1, libfreerdp2-2 2.1.1+dfsg1-0ubuntu0.20.04.1
  Ubuntu 19.10: libfreerdp-client2-2 2.1.1+dfsg1-0ubuntu0.19.10.1, libfreerdp-server2-2 2.1.1+dfsg1-0ubuntu0.19.10.1, libfreerdp2-2 2.1.1+dfsg1-0ubuntu0.19.10.1
  Ubuntu 18.04 LTS: libfreerdp-client2-2 2.1.1+dfsg1-0ubuntu0.18.04.1, libfreerdp-server2-2 2.1.1+dfsg1-0ubuntu0.18.04.1, libfreerdp2-2 2.1.1+dfsg1-0ubuntu0.18.04.1
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides a computer security note. The technology watch team tracks security threats targeting the computer system.