The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of GNOME File-roller: directory traversal via TAR Archive

Synthesis of the vulnerability 

An attacker can traverse directories via TAR Archive of GNOME File-roller, in order to read a file outside the service root path.
Vulnerable software: Debian, openSUSE Leap, Solaris, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Severity of this announce: 2/4.
Creation date: 25/09/2019.
Références of this computer vulnerability: CVE-2019-16680, DLA-1938-1, DSA-4537-1, openSUSE-SU-2020:0825-1, SUSE-SU-2020:1088-1, SUSE-SU-2020:1557-1, USN-4139-1, VIGILANCE-VUL-30409.

Description of the vulnerability 

An attacker can traverse directories via TAR Archive of GNOME File-roller, in order to read a file outside the service root path.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This computer threat announce impacts software or systems such as Debian, openSUSE Leap, Solaris, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Our Vigil@nce team determined that the severity of this computer vulnerability is medium.

The trust level is of type confirmed by the editor, with an origin of internet client.

An attacker with a expert ability can exploit this cybersecurity alert.

Solutions for this threat 

Debian 8: new file-roller packages.
New packages are available:
  Debian 8: file-roller 3.14.1-1+deb8u1

Debian 9: new file-roller packages.
New packages are available:
  Debian 9: file-roller 3.22.3-1+deb9u1

openSUSE Leap 15.1: new file-roller packages.
New packages are available:
  openSUSE Leap 15.1: file-roller 3.26.2-lp151.4.3.1

Oracle Solaris: patch for third party software of October 2019 v3.
A patch is available:
  https://support.oracle.com/rs?type=doc&id=1448883.1

SUSE LE 12: new file-roller packages.
New packages are available:
  SUSE LE 12 SP4: file-roller 3.20.3-15.3.25
  SUSE LE 12 SP5: file-roller 3.20.3-15.3.25

SUSE LE 15 SP1: new file-roller packages.
New packages are available:
  SUSE LE 15 SP1: file-roller 3.26.2-4.5.1

Ubuntu: new file-roller packages.
New packages are available:
  Ubuntu 18.04 LTS: file-roller 3.28.0-1ubuntu1.1
  Ubuntu 16.04 LTS: file-roller 3.16.5-0ubuntu1.3
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides computer security alerts. The Vigil@nce security watch publishes vulnerability bulletins about threats impacting the information system.