The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a database and tools to fix them.

computer vulnerability bulletin CVE-2017-5845

GStreamer: out-of-bounds memory reading via gst_avi_demux_parse_ncdt

Synthesis of the vulnerability

An attacker can force a read at an invalid address via gst_avi_demux_parse_ncdt() of GStreamer, in order to trigger a denial of service, or to obtain sensitive information.
Impacted products: Debian, Fedora, openSUSE Leap, RHEL, Ubuntu.
Severity: 2/4.
Creation date: 21/02/2017.
Identifiers: CVE-2017-5845, DSA-3820-1, FEDORA-2017-1fc4026d15, openSUSE-SU-2017:1066-1, openSUSE-SU-2017:1076-1, RHSA-2017:2060-01, USN-3245-1, VIGILANCE-VUL-21918.

Description of the vulnerability

An attacker can force a read at an invalid address via gst_avi_demux_parse_ncdt() of GStreamer, in order to trigger a denial of service, or to obtain sensitive information.

A detailed analysis was not performed for this bulletin.
Complete Vigil@nce bulletin.... (Free trial)

Computer vulnerabilities tracking service

Vigil@nce provides an application vulnerability alert. The Vigil@nce computer vulnerability tracking service alerts your teams of vulnerabilities or threats impacting your information system. The Vigil@nce security watch publishes vulnerability bulletins about threats impacting the information system. The technology watch team tracks security threats targeting the computer system.