The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of Ghostscript: denial of service via opj_t1_encode_cblks

Synthesis of the vulnerability 

An attacker can trigger a fatal error via opj_t1_encode_cblks() of Ghostscript, in order to trigger a denial of service.
Vulnerable systems: Debian, openSUSE Leap, Oracle Fusion Middleware, Oracle OIT, Solaris, WebLogic, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Severity of this threat: 2/4.
Creation date: 25/09/2019.
Références of this weakness: bulletinoct2019, cpujul2020, CVE-2019-12973, DLA-2277-1, openSUSE-SU-2019:2222-1, openSUSE-SU-2019:2223-1, SUSE-SU-2019:2460-1, SUSE-SU-2019:2478-1, USN-4497-1, VIGILANCE-VUL-30410.

Description of the vulnerability 

An attacker can trigger a fatal error via opj_t1_encode_cblks() of Ghostscript, in order to trigger a denial of service.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This weakness note impacts software or systems such as Debian, openSUSE Leap, Oracle Fusion Middleware, Oracle OIT, Solaris, WebLogic, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Our Vigil@nce team determined that the severity of this threat note is medium.

The trust level is of type confirmed by the editor, with an origin of document.

An attacker with a expert ability can exploit this computer weakness.

Solutions for this threat 

Debian 9: new openjpeg2 packages.
New packages are available:
  Debian 9: openjpeg2 2.1.2-1.1+deb9u5

openSUSE Leap 15: new ghostscript packages.
New packages are available:
  openSUSE Leap 15.0: ghostscript 9.27-lp150.2.23.1
  openSUSE Leap 15.1: ghostscript 9.27-lp151.3.6.1

Oracle Fusion Middleware: CPU of July 2020.
A Critical Patch Update is available:
  https://support.oracle.com/rs?type=doc&id=2664876.1

Oracle Solaris: patch for third party software of October 2019 v1.
A patch is available:
  https://support.oracle.com/rs?type=doc&id=1448883.1

SUSE LE 12: new ghostscript packages.
New packages are available:
  SUSE LE 12 SP5: ghostscript 9.27-23.28.1
  SUSE LE 12 SP4: ghostscript 9.27-23.28.1
  SUSE LE 12 SP3: ghostscript 9.27-23.28.1
  SUSE LE 12 SP2: ghostscript 9.27-23.28.1
  SUSE LE 12 SP1: ghostscript 9.27-23.28.1

SUSE LE 15: new ghostscript packages.
New packages are available:
  SUSE LE 15 RTM: ghostscript 9.27-3.21.1
  SUSE LE 15 SP1: ghostscript 9.27-3.21.1

Ubuntu 16.04: new libopenjp packages.
New packages are available:
  Ubuntu 16.04 LTS: libopenjp 2.1.2-1.1+deb9u5build0.16.04.1
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides a system vulnerability patch. The technology watch team tracks security threats targeting the computer system.