The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of GnuTLS: Man-in-the-Middle via gnutls_ocsp_resp_check_crt

Synthesis of the vulnerability 

An attacker can act as a Man-in-the-Middle via gnutls_ocsp_resp_check_crt() on GnuTLS, in order to read or write data in the session.
Impacted software: openSUSE Leap, Solaris, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Severity of this computer vulnerability: 2/4.
Creation date: 01/02/2017.
Références of this announce: bulletinjul2017, CVE-2016-7444, openSUSE-SU-2017:0386-1, RHSA-2017:2292-01, SUSE-SU-2017:0348-1, USN-3183-1, USN-3183-2, VIGILANCE-VUL-21736.

Description of the vulnerability 

An attacker can act as a Man-in-the-Middle via gnutls_ocsp_resp_check_crt() on GnuTLS, in order to read or write data in the session.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This vulnerability alert impacts software or systems such as openSUSE Leap, Solaris, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Our Vigil@nce team determined that the severity of this computer weakness alert is medium.

The trust level is of type confirmed by the editor, with an origin of internet server.

An attacker with a expert ability can exploit this computer vulnerability.

Solutions for this threat 

openSUSE Leap: new gnutls packages.
New packages are available:
  openSUSE Leap 42.1: gnutls 3.2.15-8.1
  openSUSE Leap 42.2: gnutls 3.2.15-9.1

Oracle Solaris: patch for third party software of July 2017 v3.
A patch is available:
  https://support.oracle.com/rs?type=doc&id=1448883.1

RHEL 7: new gnutls packages.
New packages are available:
  RHEL 7: gnutls 3.3.26-9.el7

SUSE LE 12: new gnutls packages.
New packages are available:
  SUSE LE 12 SP1: gnutls 3.2.15-16.1
  SUSE LE 12 SP2: gnutls 3.2.15-16.1

Ubuntu: new libgnutls packages.
New packages are available:
  Ubuntu 16.10: libgnutls30 3.5.3-5ubuntu1.1
  Ubuntu 16.04 LTS: libgnutls30 3.4.10-4ubuntu1.2
  Ubuntu 14.04 LTS: libgnutls26 2.12.23-12ubuntu2.7
  Ubuntu 12.04 LTS: libgnutls26 2.12.14-5ubuntu3.14
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides a cybersecurity database. The technology watch team tracks security threats targeting the computer system.