The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of Go: code execution via go get

Synthesis of the vulnerability 

An attacker can use a vulnerability via go get of Go, in order to run code.
Vulnerable systems: Debian, Solaris, RHEL.
Severity of this threat: 3/4.
Creation date: 30/10/2017.
Références of this weakness: CVE-2017-15041, DLA-1148-1, RHSA-2017:3463-01, RHSA-2018:0878-01, VIGILANCE-VUL-24260.

Description of the vulnerability 

An attacker can use a vulnerability via go get of Go, in order to run code.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This weakness impacts software or systems such as Debian, Solaris, RHEL.

Our Vigil@nce team determined that the severity of this vulnerability announce is important.

The trust level is of type confirmed by the editor, with an origin of internet server.

An attacker with a expert ability can exploit this threat bulletin.

Solutions for this threat 

Debian 7: new golang packages.
New packages are available:
  Debian 7: golang 2:1.0.2-1.1+deb7u2

Oracle Solaris: patch for third party software of April 2020 v2.
A patch is available:
  https://support.oracle.com/rs?type=doc&id=1448883.1

RHEL 7: new golang packages.
New packages are available:
  RHEL 7: golang 1.9.4-1.el7

RHEL 7: new go-toolset-7 packages.
New packages are available:
  RHEL 7: go-toolset-7 1.8-10.el7
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides application vulnerability analysis. The Vigil@nce vulnerability database contains several thousand vulnerabilities.