The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of Go: denial of service via Expect 100-continue Header

Synthesis of the vulnerability 

An attacker can trigger a fatal error via Expect 100-continue Header of Go, in order to trigger a denial of service.
Vulnerable software: openSUSE Leap, RHEL, SLES.
Severity of this announce: 2/4.
Creation date: 16/07/2020.
Références of this computer vulnerability: 34902, CVE-2020-15586, openSUSE-SU-2020:1087-1, openSUSE-SU-2020:1095-1, openSUSE-SU-2020:1405-1, openSUSE-SU-2020:1407-1, RHSA-2020:3665-01, SUSE-SU-2020:2562-1, VIGILANCE-VUL-32851.

Description of the vulnerability 

An attacker can trigger a fatal error via Expect 100-continue Header of Go, in order to trigger a denial of service.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This computer threat bulletin impacts software or systems such as openSUSE Leap, RHEL, SLES.

Our Vigil@nce team determined that the severity of this security threat is medium.

The trust level is of type confirmed by the editor, with an origin of internet client.

An attacker with a expert ability can exploit this computer vulnerability alert.

Solutions for this threat 

Cloud Foundry Routing Release: version 0.203.0.
The version 0.203.0 is fixed:
  https://www.cloudfoundry.org/

openSUSE Leap 15.1: new go1.13 packages.
New packages are available:
  openSUSE Leap 15.1: go1.13 1.13.14-lp151.5.1

openSUSE Leap 15.1: new go1.14 packages.
New packages are available:
  openSUSE Leap 15.1: go1.14 1.14.7-lp151.13.1

openSUSE Leap 15.2: new go1.13 packages.
New packages are available:
  openSUSE Leap 15.2: go1.13 1.13.14-lp152.2.4.1

openSUSE Leap 15.2: new go1.14 packages.
New packages are available:
  openSUSE Leap 15.2: go1.14 1.14.7-lp152.2.3.1

RHEL 8: new go-toolset-rhel8 module.
The following module is updated:
  RHEL 8 Module: go-toolset:rhel8

SUSE LE 15 SP1-2: new go1.14 packages.
New packages are available:
  SUSE LE 15 SP1: go1.14 1.14.7-1.15.1
  SUSE LE 15 SP2: go1.14 1.14.7-1.15.1

VMware Tanzu Application Service: fixed versions for Gorouter.
Fixed versions are indicated in information sources.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides applications vulnerabilities patches. The technology watch team tracks security threats targeting the computer system.