The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of Go: filter bypass

Synthesis of the vulnerability 

An attacker can make a Go program accept ill formed HTTP requests, in order to by pass filters.
Vulnerable software: Debian, Docker CE, openSUSE Leap, RHEL, SLES.
Severity of this announce: 1/4.
Creation date: 30/09/2019.
Références of this computer vulnerability: CVE-2019-16276, DSA-4534-1, openSUSE-SU-2019:2521-1, openSUSE-SU-2019:2522-1, RHSA-2020:0329-01, SUSE-SU-2019:2940-1, VIGILANCE-VUL-30469.

Description of the vulnerability 

An attacker can make a Go program accept ill formed HTTP requests, in order to by pass filters.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This security weakness impacts software or systems such as Debian, Docker CE, openSUSE Leap, RHEL, SLES.

Our Vigil@nce team determined that the severity of this threat bulletin is low.

The trust level is of type confirmed by the editor, with an origin of internet client.

An attacker with a expert ability can exploit this threat.

Solutions for this threat 

Debian 8: new golang-1.11 packages.
New packages are available:
  Debian 10: golang-1.11 1.11.6-1+deb10u2

Docker Engine/Moby: version 19.03.9.
The version 19.03.9 is fixed.

openSUSE Leap 15: new go1.12 packages.
New packages are available:
  openSUSE Leap 15.0: go1.12 1.12.12-lp150.11.1
  openSUSE Leap 15.1: go1.12 1.12.12-lp151.2.25.1

RHEL 8.1: new go-toolset-rhel8 module.
The following module is updated:
  RHEL 8.1 Module: go-toolset:rhel8

SUSE LE 15: new go1.12 packages.
New packages are available:
  SUSE LE 15 RTM: go1.12 1.12.12-1.20.1
  SUSE LE 15 SP1: go1.12 1.12.12-1.20.1

Wind River Linux: version 10.17.41.19.
The version 10.17.41.19 is fixed.

Wind River Linux: version 10.18.44.12.
The version 10.18.44.12 is fixed:
  https://support2.windriver.com/
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides an applications vulnerabilities alert. The Vigil@nce team tracks computer vulnerabilities impacting systems and applications.