The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of Google Android OS: multiple vulnerabilities of October 2015

Synthesis of the vulnerability 

An attacker can use several vulnerabilities of Google Android OS.
Vulnerable software: Android OS.
Severity of this announce: 3/4.
Number of vulnerabilities in this bulletin: 31.
Creation date: 06/10/2015.
Références of this computer vulnerability: CERTFR-2015-AVI-418, CVE-2014-9082, CVE-2015-3847, CVE-2015-3862, CVE-2015-3863, CVE-2015-3865, CVE-2015-3867, CVE-2015-3868, CVE-2015-3869, CVE-2015-3870, CVE-2015-3871, CVE-2015-3872, CVE-2015-3873, CVE-2015-3874, CVE-2015-3875, CVE-2015-3877, CVE-2015-3878, CVE-2015-3879, CVE-2015-6596, CVE-2015-6598, CVE-2015-6599, CVE-2015-6600, CVE-2015-6601, CVE-2015-6602, CVE-2015-6603, CVE-2015-6604, CVE-2015-6605, CVE-2015-6606, CVE-2015-6607, CVE-2015-7716, CVE-2015-7717, CVE-2015-7718, VIGILANCE-VUL-18049.

Description of the vulnerability 

Several vulnerabilities were announced in Google Android OS.

An attacker can use a vulnerability in libstagefright, in order to run code. [severity:3/4; CVE-2015-3873]

An attacker can use a vulnerability in libstagefright, in order to run code. [severity:3/4; CVE-2015-3872]

An attacker can use a vulnerability in libstagefright, in order to run code. [severity:3/4; CVE-2015-3871]

An attacker can use a vulnerability in libstagefright, in order to run code. [severity:3/4; CVE-2015-3868]

An attacker can use a vulnerability in libstagefright, in order to run code. [severity:3/4; CVE-2015-3867]

An attacker can use a vulnerability in libstagefright, in order to run code. [severity:3/4; CVE-2015-3869]

An attacker can use a vulnerability in libstagefright, in order to run code. [severity:3/4; CVE-2015-3870]

An attacker can use a vulnerability in libstagefright, in order to run code. [severity:3/4; CVE-2015-6598]

An attacker can use a vulnerability in libstagefright, in order to run code. [severity:3/4; CVE-2015-6599]

An attacker can use a vulnerability in libstagefright, in order to run code. [severity:3/4; CVE-2015-6600]

An attacker can use a vulnerability in libstagefright, in order to run code. [severity:3/4; CVE-2015-6601]

An attacker can use a vulnerability in libstagefright, in order to run code. [severity:3/4; CVE-2015-6604]

An attacker can use a vulnerability in Sonivox, in order to run code. [severity:3/4; CVE-2015-3874]

An attacker can use a vulnerability in libutils, in order to run code. [severity:3/4; CVE-2015-3875]

An attacker can use a vulnerability in libutils, in order to run code. [severity:3/4; CVE-2015-6602]

An attacker can use a vulnerability in Skia, in order to run code. [severity:3/4; CVE-2015-3877]

An attacker can use a vulnerability in libFLAC, in order to run code. [severity:3/4; CVE-2014-9082]

An attacker can bypass security features in KeyStore, in order to escalate his privileges. [severity:2/4; CVE-2015-3863]

An attacker can bypass security features in Media Player Framework, in order to escalate his privileges. [severity:2/4; CVE-2015-3879]

An attacker can bypass security features in Android Runtime, in order to escalate his privileges. [severity:2/4; CVE-2015-3865]

An attacker can bypass security features in Mediaserver, in order to escalate his privileges. [severity:2/4; CVE-2015-6596]

An attacker can bypass security features in Secure Element Evaluation Kit, in order to escalate his privileges. [severity:2/4; CVE-2015-6606]

An attacker can bypass security features in Media Projection, in order to escalate his privileges. [severity:2/4; CVE-2015-3878]

An attacker can bypass security features in Bluetooth, in order to escalate his privileges. [severity:2/4; CVE-2015-3847]

An attacker can bypass security features in SQLite, in order to escalate his privileges. [severity:2/4; CVE-2015-6607]

An attacker can trigger a fatal error in Mediaserver, in order to trigger a denial of service. [severity:1/4; CVE-2015-6605]

An attacker can trigger a fatal error in Mediaserver, in order to trigger a denial of service. [severity:1/4; CVE-2015-3862]

An attacker can use a vulnerability in libstagefright, in order to run code. [severity:3/4; CVE-2015-6603]

An attacker can use a vulnerability in libstagefright, in order to run code. [severity:3/4; CVE-2015-7716]

An attacker can bypass security features in mediaserver, in order to escalate his privileges. [severity:2/4; CVE-2015-7717]

An attacker can trigger a fatal error in mediaserver, in order to trigger a denial of service. [severity:2/4; CVE-2015-7718]
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This threat note impacts software or systems such as Android OS.

Our Vigil@nce team determined that the severity of this cybersecurity note is important.

The trust level is of type confirmed by the editor, with an origin of document.

This bulletin is about 31 vulnerabilities.

An attacker with a expert ability can exploit this vulnerability note.

Solutions for this threat 

Google Android OS: solution of October 2015.
The solution is indicated in information sources.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides a computers vulnerabilities watch. The Vigil@nce vulnerability database contains several thousand vulnerabilities.