The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of HP ArcSight: privilege escalation

Synthesis of the vulnerability 

A local attacker can alter files of HP ArcSight, in order to escalate his privileges.
Vulnerable products: ArcSight Connector, ArcSight ESM, ArcSight Express, ArcSight Logger, HPE ArcMC.
Severity of this weakness: 2/4.
Creation date: 04/11/2015.
Références of this bulletin: c04872416, CVE-2015-6030, HPSBGN03430, VIGILANCE-VUL-18240, VU#842252.

Description of the vulnerability 

The HP ArcSight product installs files belonging to the "arcsight" user, but run by the "root" user.

However, a local attacker with the "arcsight" privilege, can alter these files.

A local attacker can therefore alter files of HP ArcSight, in order to escalate his privileges.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This threat bulletin impacts software or systems such as ArcSight Connector, ArcSight ESM, ArcSight Express, ArcSight Logger, HPE ArcMC.

Our Vigil@nce team determined that the severity of this computer threat bulletin is medium.

The trust level is of type confirmed by the editor, with an origin of user shell.

An attacker with a expert ability can exploit this computer threat.

Solutions for this threat 

HP ArcSight ESM: version 6.5SP1P2.
The version 6.5SP1P2 is fixed:
  https://softwaresupport.hp.com/

HP ArcSight ESM: version 6.8P1.
The version 6.8P1 is fixed:
  https://softwaresupport.hp.com/

HP ArcSight Express: patch Security Update January 7 2016 for AE 4.0 Patch 1.
A patch is available:
  https://softwaresupport.hp.com/

HP ArcSight Logger: version 6.0 P2.
The version 6.0 P2 is fixed:
  https://softwaresupport.hp.com/

HP ArcSight Logger: version 6.1.
The version 6.1 is fixed:
  https://softwaresupport.hp.com/

HP ArcSight Management Center: version 2.0P2 Update 071515.
The version 2.0P2 Update 071515 is fixed:
  https://softwaresupport.hp.com/

HP ArcSight Management Center: version 2.1.
The version 2.1 is fixed:
  https://softwaresupport.hp.com/

HP ArcSight SmartConnector: version 7.1.6.
The version 7.1.6 is fixed:
  https://softwaresupport.hp.com/
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides a network vulnerability patch. The Vigil@nce computer vulnerability tracking service alerts your teams of vulnerabilities or threats impacting your information system.