The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a database and tools to fix them.

threat CVE-2005-3779

HP-UX: privilege increase with xterm

Synthesis of the vulnerability

A local attacker can use xterm to increase his privileges.
Severity of this computer vulnerability: 2/4.
Number of vulnerabilities in this bulletin: 2.
Creation date: 14/11/2005.
Références of this announce: BID-15412, c00555516, CVE-2005-3779, CVE-2006-2125-REJECT, HPSBUX02075, SSRT051074, VIGILANCE-VUL-5356.
Full Vigil@nce bulletin... (Free trial)

Description of the vulnerability

The /usr/bin/X11/xterm command is installed suid root. A vulnerability affects xterm when following patches are installed:
  HP-UX B.11.00 : PHSS_32109
  HP-UX B.11.11 : PHSS_30791, PHSS_33589
  HP-UX B.11.23 : PHSS_31833, PHSS_32366

 This vulnerability permits a local attacker to increase his privileges.
Full Vigil@nce bulletin... (Free trial)

This computer threat impacts software or systems such as HP-UX.

Our Vigil@nce team determined that the severity of this computer vulnerability alert is medium.

The trust level is of type confirmed by the editor, with an origin of user shell.

This bulletin is about 2 vulnerabilities.

An attacker with a expert ability can exploit this cybersecurity weakness.

Solutions for this threat

HP-UX: patch for xterm.
A patch is available:
  HP-UX B.11.00 : PHSS_34160
  HP-UX B.11.11 : PHSS_34102
  HP-UX B.11.23 : PHSS_34159
A workaround is to remove following patches:
  HP-UX B.11.00, X11.X11-RUN-CL
    PHSS_32109
  HP-UX B.11.11, X11.X11-RUN-CL
    PHSS_30791, PHSS_33589
  HP-UX B.11.23, X11.X11-RUN-CL
    PHSS_31833, PHSS_32366
Another solution is to change xterm command:
  cp /usr/bin/X11/xterm /usr/bin/X11/xterm.nosuid
  chmod 555 /usr/bin/X11/xterm.nosuid
  cp /usr/contrib/bin/X11R5/xterm /usr/bin/X11/xterm
A preliminary xterm program is also proposed in the announce.
Full Vigil@nce bulletin... (Free trial)

Computer vulnerabilities tracking service

Vigil@nce provides applications vulnerabilities announces. The Vigil@nce team tracks computer vulnerabilities impacting systems and applications. The technology watch team tracks security threats targeting the computer system. The Vigil@nce security watch publishes vulnerability bulletins about threats impacting the information system.