The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of Horde: privilege elevation and Cross Site Scripting

Synthesis of the vulnerability 

An attacker can elevate his privileges or create a Cross Site Scripting attack in Horde.
Impacted software: Debian, Fedora, Chora, openSUSE, SLES, Unix (platform) ~ not comprehensive.
Severity of this computer vulnerability: 3/4.
Number of vulnerabilities in this bulletin: 2.
Creation date: 10/01/2008.
Références of this announce: BID-27217, BID-27223, CERTA-2002-AVI-197, CERTA-2008-AVI-032, CVE-2007-6018, CVE-2008-7218, CVE-2008-7219, DSA-1470-1, FEDORA-2008-2040, FEDORA-2008-2087, FEDORA-2008-2221, SUSE-SR:2009:007, VIGILANCE-VUL-7480.

Description of the vulnerability 

The Horde environment proposes features for web application development. It has two vulnerabilities, which also affect derivative applications.

The lib/Horde/Text/Filter/xss.php file implements filters against Cross Site Scripting attacks. However, these filters are not complete, and for example do not handle the FRAME tag. [severity:2/4; CERTA-2008-AVI-032, CVE-2007-6018]

The lib/api.php file implements functions frequently used by Horde. However, some privileged functions do no check if the user is an administrator. Here is the list of affected functions : _horde_removeUserData(), _horde_addGroup(), _horde_removeGroup(), _horde_addUserToGroup(), _horde_addUsersToGroup(), _horde_removeUserFromGroup(), _horde_removeUsersFromGroup(), _horde_listUsersOfGroup(), _horde_addShare(), _horde_removeShare(), _horde_listSharesOfOwner(), _horde_addUserPermissions(), _horde_addGroupPermissions(), _horde_removeUserPermissions(), _horde_removeGroupPermissions(), _horde_listUserPermissions(), _horde_listGroupPermissions(), _horde_listUsersOfShare(), _horde_listGroupsOfShare(). [severity:3/4; CVE-2008-7219]
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This vulnerability alert impacts software or systems such as Debian, Fedora, Chora, openSUSE, SLES, Unix (platform) ~ not comprehensive.

Our Vigil@nce team determined that the severity of this computer weakness alert is important.

The trust level is of type confirmed by the editor, with an origin of user account.

This bulletin is about 2 vulnerabilities.

An attacker with a expert ability can exploit this computer vulnerability.

Solutions for this threat 

Horde: version 3.1.6.
Version 3.1.6 is corrected:
  ftp://ftp.horde.org/pub/horde/horde-3.1.6.tar.gz
  http://ftp.horde.org/pub/horde/horde-3.1.6.tar.gz
New versions are also available for derivative versions, as indicated in announces.

Debian 4.0: new horde3 packages.
New packages are available:
Source archives:
  http://security.debian.org/pool/updates/main/h/horde3/horde3_3.1.3-4etch2.dsc
    Size/MD5 checksum: 682 65c2b4458281e2e4c844b7bd4af52ba3
  http://security.debian.org/pool/updates/main/h/horde3/horde3_3.1.3-4etch2.diff.gz
    Size/MD5 checksum: 12893 db60e2c62f488824247429c35ace45fd
  http://security.debian.org/pool/updates/main/h/horde3/horde3_3.1.3.orig.tar.gz
    Size/MD5 checksum: 5232958 fbc56c608ac81474b846b1b4b7bb5ee7
Architecture independent packages:
  http://security.debian.org/pool/updates/main/h/horde3/horde3_3.1.3-4etch2_all.deb
    Size/MD5 checksum: 5261396 e1cff2548fbd2f1984e2cf956ecd43f8

Fedora 7: new horde packages.
New packages are available:
  horde-3.1.6-1.fc7

Fedora 7: new imp packages.
New packages are available:
  imp-4.1.6-1.fc7

Fedora 8: new horde packages.
New packages are available:
  horde-3.1.6-1.fc8

Fedora 8: new imp packages.
New packages are available:
  imp-4.1.6-1.fc8

Fedora 8: new kronolith packages.
New packages are available:
  kronolith-2.1.7-1.fc8

SUSE: new vim, gvim, apache2, opera, multipath tools, java-1_6_0-openjdk, imp, horde, lcms, moodle, ghostscript packages.
New packages are available.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides software vulnerabilities announces. The Vigil@nce computer vulnerability tracking service alerts your teams of vulnerabilities or threats impacting your information system.