The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of IBM WebSphere MQ: out-of-bounds memory reading via MQ Protocol

Synthesis of the vulnerability 

An attacker can force a read at an invalid address via MQ Protocol of IBM WebSphere MQ, in order to trigger a denial of service, or to obtain sensitive information.
Vulnerable software: QRadar SIEM, WebSphere MQ.
Severity of this announce: 2/4.
Creation date: 20/09/2016.
Références of this computer vulnerability: 1984565, 2015824, 7014224, 7043086, CVE-2016-0379, VIGILANCE-VUL-20653.

Description of the vulnerability 

An attacker can force a read at an invalid address via MQ Protocol of IBM WebSphere MQ, in order to trigger a denial of service, or to obtain sensitive information.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This vulnerability note impacts software or systems such as QRadar SIEM, WebSphere MQ.

Our Vigil@nce team determined that the severity of this cybersecurity vulnerability is medium.

The trust level is of type confirmed by the editor, with an origin of user account.

An attacker with a expert ability can exploit this computer threat note.

Solutions for this threat 

IBM WebSphere MQ: version 8.0.0.5.
The version 8.0.0.5 is fixed.

IBM WebSphere MQ: version 7.5.0.7.
The version 7.5.0.7 is fixed:
  http://www-01.ibm.com/support/docview.wss?uid=swg21983301

IBM WebSphere MQ: version 7.0.1.14.
The version 7.0.1.14 is fixed:
  http://www.ibm.com/support/docview.wss?uid=swg21979626

IBM QRadar SIEM: solution for WebSphere MQ.
The solution is indicated in information sources.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides a software vulnerability workaround. The Vigil@nce team tracks computer vulnerabilities impacting systems and applications.