The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of ISC BIND: memory leak via EDNS Options

Synthesis of the vulnerability 

An attacker can create a memory leak via EDNS Options of ISC BIND, in order to trigger a denial of service.
Impacted software: BIG-IP Hardware, TMOS, IBM i, BIND, Solaris, Synology DSM, Ubuntu.
Severity of this computer vulnerability: 3/4.
Creation date: 22/02/2019.
Références of this announce: bulletinapr2019, CERTFR-2019-AVI-076, CERTFR-2019-AVI-242, CVE-2018-5744, ibm10876698, K00040234, K01713115, K25244852, Synology-SA-19:10, USN-3893-1, USN-3893-2, VIGILANCE-VUL-28582.

Description of the vulnerability 

An attacker can create a memory leak via EDNS Options of ISC BIND, in order to trigger a denial of service.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This security announce impacts software or systems such as BIG-IP Hardware, TMOS, IBM i, BIND, Solaris, Synology DSM, Ubuntu.

Our Vigil@nce team determined that the severity of this threat is important.

The trust level is of type confirmed by the editor, with an origin of internet client.

An attacker with a expert ability can exploit this computer vulnerability announce.

Solutions for this threat 

ISC BIND: version 9.12.3-P4.
The version 9.12.3-P4 is fixed:
  https://www.isc.org/downloads
  https://ftp.isc.org/isc/bind9/

ISC BIND: version 9.11.5-P4.
The version 9.11.5-P4 is fixed:
  https://www.isc.org/downloads
  https://ftp.isc.org/isc/bind9/

ISC BIND: version 9.13.7 Dev.
The version 9.13.7 is fixed:
  https://www.isc.org/downloads
  https://ftp.isc.org/isc/bind9/

F5 BIG-IP: versions 14.1.0.2, 12.1.4.1, 11.6.4, 11.5.9.
Versions 14.1.0.2 and 12.1.4.1 are fixed.
Versions 11.6.4 and 11.5.9 are partially fixed.

IBM i: patch for BIND.
A patch is indicated in information sources.

Oracle Solaris: patch for third party software of April 2019 v1.
A patch is available:
  https://support.oracle.com/rs?type=doc&id=1448883.1

Ubuntu: new bind9 packages.
New packages are available:
  Ubuntu 18.10: bind9 1:9.11.4+dfsg-3ubuntu5.1
  Ubuntu 18.04 LTS: bind9 1:9.11.3+dfsg-1ubuntu1.5
  Ubuntu 16.04 LTS: bind9 1:9.10.3.dfsg.P4-8ubuntu1.12
  Ubuntu 14.04 LTS: bind9 1:9.9.5.dfsg-3ubuntu0.19
  Ubuntu 12.04 ESM: bind9 1:9.8.1.dfsg.P1-4ubuntu0.27

Wind River Linux: version 10.18.44.12.
The version 10.18.44.12 is fixed:
  https://support2.windriver.com/
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides systems vulnerabilities alerts. The Vigil@nce vulnerability database contains several thousand vulnerabilities.