The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of LibVNCServer: five vulnerabilities

Synthesis of the vulnerability 

An attacker can use several vulnerabilities of LibVNCServer.
Impacted software: Debian, openSUSE Leap, Ubuntu.
Severity of this computer vulnerability: 2/4.
Number of vulnerabilities in this bulletin: 5.
Creation date: 04/12/2015.
Références of this announce: CVE-2014-6051, CVE-2014-6052, CVE-2014-6053, CVE-2014-6054, CVE-2014-6055, DLA-1979-1, DLA-2014-1, DLA-2045-1, openSUSE-SU-2015:2207-1, USN-4573-1, USN-4587-1, VIGILANCE-VUL-18442.

Description of the vulnerability 

Several vulnerabilities were announced in LibVNCServer.

An attacker can generate an integer overflow in MallocFrameBuffer, in order to trigger a denial of service, and possibly to run code. [severity:2/4; CVE-2014-6051]

An attacker can generate a memory corruption in malloc, in order to trigger a denial of service, and possibly to run code. [severity:2/4; CVE-2014-6052]

An attacker can trigger a fatal error in ClientCutText, in order to trigger a denial of service. [severity:2/4; CVE-2014-6053]

An attacker can trigger a fatal error in Scaling Factor, in order to trigger a denial of service. [severity:2/4; CVE-2014-6054]

An attacker can generate a buffer overflow in File Transfer, in order to trigger a denial of service, and possibly to run code. [severity:2/4; CVE-2014-6055]
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This weakness note impacts software or systems such as Debian, openSUSE Leap, Ubuntu.

Our Vigil@nce team determined that the severity of this threat note is medium.

The trust level is of type confirmed by the editor, with an origin of intranet client.

This bulletin is about 5 vulnerabilities.

An attacker with a expert ability can exploit this computer weakness.

Solutions for this threat 

Debian 8: new italc packages.
New packages are available:
  Debian 8: italc 1:2.0.2+dfsg1-2+deb8u1

Debian 8: new tightvnc packages.
New packages are available:
  Debian 8: tightvnc 1.3.9-6.5+deb8u1

Debian 8: new vino packages.
New packages are available:
  Debian 8: vino 3.14.0-2+deb8u1

openSUSE Leap 42.1: new LibVNCServer packages.
New packages are available:
  openSUSE Leap 42.1: LibVNCServer 0.9.9-13.1

Ubuntu 16.04: new italc packages.
New packages are available:
  Ubuntu 16.04 LTS: italc 1:2.0.2+dfsg1-4ubuntu0.1

Ubuntu: new vino packages.
New packages are available:
  Ubuntu 20.04 LTS: vino 3.22.0-5ubuntu2.1
  Ubuntu 18.04 LTS: vino 3.22.0-3ubuntu1.1
  Ubuntu 16.04 LTS: vino 3.8.1-0ubuntu9.3
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides a computers vulnerabilities database. The Vigil@nce team tracks computer vulnerabilities impacting systems and applications.