The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of Libreswan: Man-in-the-Middle via IKEv1 Informational Exchange Packets

Synthesis of the vulnerability 

An attacker can act as a Man-in-the-Middle via IKEv1 Informational Exchange Packets on Libreswan, in order to read or write data in the session.
Impacted software: Fedora, Openswan, RHEL.
Severity of this computer vulnerability: 2/4.
Creation date: 13/06/2019.
Références of this announce: CVE-2019-10155, FEDORA-2019-f7fb531958, RHSA-2019:3391-01, VIGILANCE-VUL-29524.

Description of the vulnerability 

An attacker can act as a Man-in-the-Middle via IKEv1 Informational Exchange Packets on Libreswan, in order to read or write data in the session.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This vulnerability alert impacts software or systems such as Fedora, Openswan, RHEL.

Our Vigil@nce team determined that the severity of this computer weakness alert is medium.

The trust level is of type confirmed by the editor, with an origin of internet server.

An attacker with a expert ability can exploit this computer vulnerability.

Solutions for this threat 

Fedora 30: new libreswan packages.
New packages are available:
  Fedora 30: libreswan 3.29-1.fc30

Openswan: version 2.6.51.4.
The version 2.6.51.4 is fixed:
  https://download.openswan.org/openswan/openswan-2.6.51.4.tar.gz

RHEL 8: new libreswan packages.
New packages are available:
  RHEL 8: libreswan 3.29-6.el8
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides systems vulnerabilities alerts. The Vigil@nce team tracks computer vulnerabilities impacting systems and applications.