The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of Linux kernel: NULL pointer dereference via net/rds/connection.c

Synthesis of the vulnerability 

A local attacker can force a NULL pointer to be dereferenced in net/rds/connection.c of the Linux kernel, in order to trigger a denial of service.
Vulnerable products: Debian, Fedora, Linux, openSUSE, openSUSE Leap, Solaris, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Severity of this weakness: 1/4.
Creation date: 15/09/2015.
Références of this bulletin: CERTFR-2015-AVI-435, CERTFR-2015-AVI-436, CERTFR-2015-AVI-508, CERTFR-2015-AVI-563, CERTFR-2016-AVI-050, cpuoct2018, CVE-2015-6937, DSA-3364-1, FEDORA-2015-16440, FEDORA-2015-16441, openSUSE-SU-2015:2232-1, openSUSE-SU-2016:0301-1, openSUSE-SU-2016:0318-1, openSUSE-SU-2016:2649-1, SUSE-SU-2015:1727-1, SUSE-SU-2015:2108-1, SUSE-SU-2015:2339-1, SUSE-SU-2015:2350-1, SUSE-SU-2016:0354-1, SUSE-SU-2016:2074-1, USN-2773-1, USN-2774-1, USN-2775-1, USN-2776-1, USN-2777-1, USN-2778-1, USN-2779-1, VIGILANCE-VUL-17886.

Description of the vulnerability 

The Linux kernel implements RDS (Reliable Datagram Sockets).

However, if the socket is not bound before sending a message, the net/rds/connection.c file does not check if the "trans" (transport) pointer is NULL, before using it.

A local attacker can therefore force a NULL pointer to be dereferenced in net/rds/connection.c of the Linux kernel, in order to trigger a denial of service.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This cybersecurity threat impacts software or systems such as Debian, Fedora, Linux, openSUSE, openSUSE Leap, Solaris, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Our Vigil@nce team determined that the severity of this computer threat note is low.

The trust level is of type confirmed by the editor, with an origin of user account.

An attacker with a expert ability can exploit this security threat.

Solutions for this threat 

Linux kernel: version 3.18.26.
The version 3.18.26 is fixed:
  https://cdn.kernel.org/pub/linux/kernel/v3.x/linux-3.18.26.tar.xz

Linux kernel: version 2.6.32.70.
The version 2.6.32.70 is fixed:
  https://cdn.kernel.org/pub/linux/kernel/v2.6/longterm/v2.6.32/linux-2.6.32.70.tar.xz

Linux kernel: patch for net/rds/connection.c.
A patch is indicated in information sources.
This patch has to be completed with VIGILANCE-SOL-43292.

Debian: new linux packages (22/09/2015).
New packages are available:
  Debian 7: linux 3.2.68-1+deb7u4
  Debian 8: linux 3.16.7-ckt11-1+deb8u4

Fedora: new kernel packages.
New packages are available:
  Fedora 21: kernel 4.1.8-100.fc21
  Fedora 22: kernel 4.1.8-200.fc22

openSUSE 11.4: new kernel packages.
New packages are available:
  openSUSE 11.4: kernel 3.0.101-105.1

openSUSE 13.1: new kernel packages (01/02/2016).
New packages are available:
  openSUSE 13.1: kernel 3.11.10-32.1

openSUSE 13.2: new kernel packages (03/02/2016).
New packages are available:
  openSUSE 13.2: kernel 3.16.7-32.1

openSUSE Leap 42.1: new kernel packages (09/12/2015).
New packages are available:
  openSUSE Leap 42.1: kernel 4.1.13-5.1

Oracle Solaris: CPU of Octobre 2018.
A Critical Patch Update is available:
  https://support.oracle.com/rs?type=doc&id=2451130.1

SUSE LE 11 SP2: new kernel packages (16/08/2016).
New packages are available:
  SUSE LE 11 SP2: kernel 3.0.101-0.7.40.1

SUSE LE 11 SP3: new kernel packages.
New packages are available:
  SUSE LE 11 SP3: kernel 3.0.101-0.47.71.3

SUSE LE 11 SP3: new kernel-rt packages.
New packages are available:
  SUSE LE 11 SP3: kernel-rt 3.0.101.rt130-0.33.44.2

SUSE LE 11 SP4: new kernel packages.
New packages are available:
  SUSE LE 11 SP4: kernel 3.0.101-68.2

SUSE LE 11 SP4: new kernel-rt packages.
New packages are available:
  SUSE LE 11 SP4: kernel-rt 3.0.101.rt130-48.1

SUSE LE 12: new kernel packages (13/10/2015).
New packages are available:
  SUSE LE 12 RTM: kernel 3.12.48-52.27.1

Ubuntu 12.04: new linux-image-3.2.0 packages.
New packages are available:
  Ubuntu 12.04 LTS: linux-image-3.2.0-92-generic 3.2.0-92.130, linux-image-3.2.0-1472-omap4 3.2.0-1472.93

Ubuntu 14.04: new linux-image-3.16.0-51 packages.
New packages are available:
  Ubuntu 14.04 LTS: linux-image-3.16.0-51 3.16.0-51.69~14.04.1

Ubuntu: new linux-image-3.13.0-66-generic packages.
New packages are available:
  Ubuntu 12.04 LTS: linux-image-3.13.0 66-generic 3.13.0-66.108~precise1
  Ubuntu 14.04 LTS: linux-image-3.13.0 66-generic 3.13.0-66.108

Ubuntu: new linux-image-3.19.0 packages.
New packages are available:
  Ubuntu 14.04 LTS: linux-image-3.19.0 3.19.0-31.36~14.04.1
  Ubuntu 15.04: linux-image-3.19.0 3.19.0-31.36
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides a computer vulnerability watch. The Vigil@nce vulnerability database contains several thousand vulnerabilities.