The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of Linux kernel: NULL pointer dereference via nfsd4_verify_copy

Synthesis of the vulnerability 

An attacker can force a NULL pointer to be dereferenced via nfsd4_verify_copy() of the Linux kernel, in order to trigger a denial of service.
Vulnerable systems: QRadar SIEM, Linux, openSUSE Leap, RHEL, SUSE Linux Enterprise Desktop, SLES.
Severity of this threat: 1/4.
Creation date: 03/06/2019.
Références of this weakness: 1103505, CERTFR-2019-AVI-306, CERTFR-2019-AVI-337, CERTFR-2019-AVI-361, CERTFR-2019-AVI-440, CERTFR-2019-AVI-458, CERTFR-2020-AVI-147, CERTFR-2020-AVI-243, CERTFR-2020-AVI-253, CVE-2018-16871, openSUSE-SU-2019:1716-1, openSUSE-SU-2019:1757-1, RHSA-2019:1873-01, RHSA-2019:1891-01, RHSA-2019:2696-01, RHSA-2019:2730-01, RHSA-2020:0740-01, RHSA-2020:1567-01, RHSA-2020:1769-01, RHSA-2020:1966-01, SUSE-SU-2019:1744-1, SUSE-SU-2019:1851-1, SUSE-SU-2019:1855-1, SUSE-SU-2019:2430-1, SUSE-SU-2019:2450-1, VIGILANCE-VUL-29444.

Description of the vulnerability 

An attacker can force a NULL pointer to be dereferenced via nfsd4_verify_copy() of the Linux kernel, in order to trigger a denial of service.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This computer vulnerability impacts software or systems such as QRadar SIEM, Linux, openSUSE Leap, RHEL, SUSE Linux Enterprise Desktop, SLES.

Our Vigil@nce team determined that the severity of this weakness bulletin is low.

The trust level is of type confirmed by the editor, with an origin of user account.

An attacker with a expert ability can exploit this weakness.

Solutions for this threat 

Linux kernel: version 4.19.3.
The version 4.19.3 is fixed:
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Linux kernel: version 4.18.20.
The version 4.18.20 is fixed:
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Linux kernel: version 4.14.82.
The version 4.14.82 is fixed:
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Linux kernel: version 4.9.138.
The version 4.9.138 is fixed:
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Linux kernel: patch for nfsd4_verify_copy.
A patch is indicated in information sources.

IBM QRadar SIEM: patch for Kernel.
A patch is indicated in information sources.

openSUSE Leap 15.0: new kernel packages.
New packages are available:
  openSUSE Leap 15.0: kernel 4.12.14-lp150.12.67.1

openSUSE Leap 15.1: new kernel packages.
New packages are available:
  openSUSE Leap 15.1: kernel debug-4.12.14-lp151.28.10.1

RHEL 6: new kernel-rt packages.
New packages are available:
  RHEL 6: kernel-rt 3.10.0-693.58.1.rt56.652.el6rt

RHEL 7.4: new kernel packages.
New packages are available:
  RHEL 7: kernel 3.10.0-693.58.1.el7

RHEL 7.7: new kernel-alt packages.
New packages are available:
  RHEL 7.0-7.7: kernel-alt 4.14.0-115.18.1.el7a

RHEL 7: new kernel packages.
New packages are available:
  RHEL 7: kernel 3.10.0-957.27.2.el7

RHEL 7: new kernel-rt packages.
New packages are available:
  RHEL 7: kernel-rt 3.10.0-957.27.2.rt56.940.el7

RHEL 8: new kernel packages.
New packages are available:
  RHEL 8.0-8.1: kernel 4.18.0-193.el8

RHEL 8: new kernel-rt packages.
New packages are available:
  RHEL 8.0-8.1: kernel-rt 4.18.0-193.rt13.51.el8

SUSE LE 12 SP4: new kernel packages (16/07/2019).
New packages are available:
  SUSE LE 12 SP4: kernel 4.12.14-95.24.1

SUSE LE 12 SP4: new kernel-rt packages.
New packages are available:
  SUSE LE 12 SP4: kernel-rt 4.12.14-8.3.1

SUSE LE 15 RTM: new kernel packages.
New packages are available:
  SUSE LE 15 RTM: kernel 4.12.14-150.27.1

SUSE LE 15 SP1: new kernel packages.
New packages are available:
  SUSE LE 15 SP1: kernel 4.12.14-197.7.1

SUSE LE 15 SP1: new kernel-source-rt packages.
New packages are available:
  SUSE LE 15 SP1: kernel-source-rt 4.12.14-14.8.1
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides a system vulnerability alert. The Vigil@nce computer vulnerability tracking service alerts your teams of vulnerabilities or threats impacting your information system.