The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of Linux kernel: NULL pointer dereference via usbnet

Synthesis of the vulnerability 

An attacker can plug a malicious USB device, to force a NULL pointer to be dereferenced in usbnet of the Linux kernel, in order to trigger a denial of service.
Impacted software: Debian, Fedora, Android OS, Linux, openSUSE, openSUSE Leap, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Severity of this computer vulnerability: 1/4.
Creation date: 07/04/2016.
Références of this announce: CERTFR-2016-AVI-156, CERTFR-2016-AVI-186, CERTFR-2016-AVI-199, CERTFR-2016-AVI-220, CVE-2016-3951, DLA-516-1, DSA-3607-1, FEDORA-2016-373c063e79, FEDORA-2016-8e858f96b8, openSUSE-SU-2016:1382-1, openSUSE-SU-2016:2144-1, SUSE-SU-2016:1690-1, SUSE-SU-2016:1696-1, SUSE-SU-2016:1764-1, USN-2965-1, USN-2965-2, USN-2965-3, USN-2965-4, USN-2989-1, USN-2998-1, USN-3000-1, USN-3001-1, USN-3002-1, USN-3003-1, USN-3004-1, USN-3021-1, USN-3021-2, VIGILANCE-VUL-19318.

Description of the vulnerability 

The Linux kernel implements the support of network devices on USB.

However, if an USB device uses a malformed descriptor, the drivers/net/usb/usbnet.c file does not check if a pointer is NULL, before using it.

An attacker can therefore plug a malicious USB device, to force a NULL pointer to be dereferenced in usbnet of the Linux kernel, in order to trigger a denial of service.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This computer weakness bulletin impacts software or systems such as Debian, Fedora, Android OS, Linux, openSUSE, openSUSE Leap, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Our Vigil@nce team determined that the severity of this computer threat announce is low.

The trust level is of type confirmed by the editor, with an origin of physical access.

An attacker with a expert ability can exploit this threat announce.

Solutions for this threat 

Linux kernel: version 3.18.54.
The version 3.18.54 is fixed:
  https://cdn.kernel.org/pub/linux/kernel/v3.x/

Linux kernel: version 3.10.103.
The version 3.10.103 is fixed:
  https://cdn.kernel.org/pub/linux/kernel/v3.x/

Linux kernel: patch for usbnet.
A patch is indicated in information sources.

Android OS: patch 2016-09-05.
A patch is indicated in information sources.

Debian 7: new linux packages.
New packages are available:
  Debian 7: linux 3.2.81-1

Debian 8: new linux packages.
New packages are available:
  Debian 8: linux 3.16.7-ckt25-2+deb8u2

Fedora 22: new kernel packages.
New packages are available:
  Fedora 22: kernel 4.4.8-200.fc22

Fedora 23: new kernel packages.
New packages are available:
  Fedora 23: kernel 4.4.7-300.fc23

openSUSE 13.2: new kernel packages.
New packages are available:
  openSUSE 13.2: kernel 3.16.7-42.1

openSUSE Leap 42.1: new kernel packages (24/05/2016).
New packages are available:
  openSUSE Leap 42.1: kernel 4.1.21-14.2

SUSE LE 12: new kernel packages.
New packages are available:
  SUSE LE 12 SP1: kernel 3.12.59-60.41.2

SUSE LE 12 SP1: new kernel-rt packages.
New packages are available:
  SUSE LE 12 SP1: kernel-rt 3.12.58-14.1

SUSE LE: new kernel packages.
New packages are available:
  SUSE LE 12 RTM: kernel 3.12.60-52.49.1

Ubuntu 12.04 LTS: new linux-image-3.13.0-88-generic packages.
New packages are available:
  Ubuntu 12.04 LTS: linux-image-3.13.0-88-generic 3.13.0-88.135~precise1

Ubuntu 14.04 LTS: new linux-image-3.16.0-73-generic packages.
New packages are available:
  Ubuntu 14.04 LTS: linux-image-3.16.0-73-generic 3.16.0-73.95~14.04.1

Ubuntu 14.04: new linux-image-3.13.0-87 packages.
New packages are available:
  Ubuntu 14.04 LTS: linux-image-3.13.0-87 3.13.0-87.133

Ubuntu 14.04: new linux-image-4.2.0-38 packages.
New packages are available:
  Ubuntu 14.04 LTS: linux-image-4.2.0-38 4.2.0-38.45~14.04.1

Ubuntu 15.10: new linux-image-4.2.0-1031-raspi2 packages.
New packages are available:
  Ubuntu 15.10: linux-image-4.2.0-1031-raspi2 4.2.0-1031.41

Ubuntu: new linux-image-4.4.0-22 packages.
New packages are available:
  Ubuntu 14.04 LTS: linux-image-4.4.0-22 4.4.0-22.39~14.04.1
  Ubuntu 16.04 LTS: linux-image-4.4.0-22 4.4.0-22.39

Ubuntu: new linux-image packages (10/06/2016).
New packages are available:
  Ubuntu 15.10: linux-image-4.2.0-38-generic 4.2.0-38.45
  Ubuntu 14.04 LTS: linux-image-3.19.0-61-generic 3.19.0-61.69~14.04.1

Ubuntu: new linux-image packages (28/06/2016).
New packages are available:
  Ubuntu 12.04 LTS: linux-image-3.2.0-1483-omap4 3.2.0-1483.110
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides a software vulnerabilities watch. The Vigil@nce vulnerability database contains several thousand vulnerabilities.