The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of Linux kernel, Xen: privilege escalation via PV Backend Driver

Synthesis of the vulnerability 

An attacker, who is administrator in a guest system, can access to the memory of the PV Backend Driver of Xen, in order to escalate his privileges on the host system.
Impacted systems: Debian, Fedora, Linux, NetBSD, openSUSE, openSUSE Leap, SUSE Linux Enterprise Desktop, SLES, Ubuntu, Xen.
Severity of this alert: 2/4.
Creation date: 17/12/2015.
Références of this alert: CERTFR-2015-AVI-551, CERTFR-2015-AVI-558, CERTFR-2016-AVI-004, CERTFR-2016-AVI-044, CERTFR-2016-AVI-073, CERTFR-2016-AVI-110, CVE-2015-8550, DLA-479-1, DSA-3434-1, DSA-3471-1, DSA-3519-1, FEDORA-2015-c44bd3e0fa, FEDORA-2015-d8253e2b1d, openSUSE-SU-2016:0123-1, openSUSE-SU-2016:0124-1, openSUSE-SU-2016:0126-1, openSUSE-SU-2016:0280-1, openSUSE-SU-2016:0301-1, openSUSE-SU-2016:0318-1, SUSE-SU-2016:0168-1, SUSE-SU-2016:0585-1, SUSE-SU-2016:0658-1, SUSE-SU-2016:0873-1, SUSE-SU-2016:0911-1, SUSE-SU-2016:0955-1, SUSE-SU-2016:1102-1, SUSE-SU-2016:1154-1, SUSE-SU-2016:1203-1, SUSE-SU-2016:1318-1, SUSE-SU-2016:1745-1, SUSE-SU-2016:1764-1, USN-2846-1, USN-2847-1, USN-2848-1, USN-2849-1, USN-2850-1, USN-2851-1, USN-2852-1, USN-2853-1, USN-2854-1, USN-2886-1, USN-2886-2, USN-2891-1, VIGILANCE-VUL-18551, XSA-155.

Description of the vulnerability 

The Xen product uses PV Backend drivers.

However, due an optimization by the compiler, the Frontend can access to the Backend memory.

An attacker, who is administrator in a guest system, can therefore access to the memory of the PV Backend Driver of Xen, in order to escalate his privileges on the host system.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This computer threat bulletin impacts software or systems such as Debian, Fedora, Linux, NetBSD, openSUSE, openSUSE Leap, SUSE Linux Enterprise Desktop, SLES, Ubuntu, Xen.

Our Vigil@nce team determined that the severity of this security threat is medium.

The trust level is of type confirmed by the editor, with an origin of privileged shell.

An attacker with a expert ability can exploit this computer vulnerability alert.

Solutions for this threat 

Linux kernel, Xen: patch for PV Backend Driver.
A patch is available:
  http://xenbits.xen.org/xsa/advisory-155.html

Linux kernel: version 4.1.20.
The version 4.1.20 is fixed:
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Linux kernel: version 3.18.29.
The version 3.18.29 is fixed:
  https://cdn.kernel.org/pub/linux/kernel/v3.x/

Debian 7: new xen packages.
New packages are available:
  Debian 7: xen 4.1.6.1-1+deb7u1

Debian 8: new qemu packages.
New packages are available:
  Debian 8: qemu 1:2.1+dfsg-12+deb8u5a

Debian: new linux packages (06/01/2016).
New packages are available:
  Debian 7: linux 3.2.73-2+deb7u2
  Debian 8: linux 3.16.7-ckt20-1+deb8u2

Debian: new xen packages.
New packages are available:
  Debian 8: xen 4.4.1-9+deb8u4

Fedora: new xen packages.
New packages are available:
  Fedora 22: xen 4.5.2-6.fc22
  Fedora 23: xen 4.5.2-6.fc23

openSUSE 13.1: new kernel packages (01/02/2016).
New packages are available:
  openSUSE 13.1: kernel 3.11.10-32.1

openSUSE 13.1: new xen packages (15/01/2016).
New packages are available:
  openSUSE 13.1: xen 4.3.4_10-53.1

openSUSE 13.2: new kernel packages (03/02/2016).
New packages are available:
  openSUSE 13.2: kernel 3.16.7-32.1

openSUSE 13.2: new xen packages (15/01/2016).
New packages are available:
  openSUSE 13.2: xen 4.4.3_08-36.1

openSUSE Leap 42.1: new kernel packages (29/01/2016).
New packages are available:
  openSUSE Leap 42.1: kernel pae-4.1.15-8.1

openSUSE Leap 42.1: new xen packages (15/01/2016).
New packages are available:
  openSUSE Leap 42.1: xen 4.5.2_04-9.2

SUSE LE 10: new xen packages (07/03/2016).
New packages are available:
  SUSE LE 10 SP4: xen 3.2.3_17040_46-0.23.2

SUSE LE 11: new kernel packages.
New packages are available:
  SUSE LE 11 SP4: kernel 3.0.101-71.2

SUSE LE 11 SP2: new xen packages (27/04/2016).
New packages are available:
  SUSE LE 11 SP2: xen 4.1.6_08-26.1

SUSE LE 11 SP3: new kernel packages (04/05/2016).
New packages are available:
  SUSE LE 11 SP3: kernel 3.0.101-0.47.79.1

SUSE LE 11 SP3: new xen packages (06/07/2016).
New packages are available:
  SUSE LE 11 SP3: xen-kmp-default 4.2.5_20_3.0.101_0.47.79-24.9, xen-libs 4.2.5_20-24.9, xen-tools-domU 4.2.5_20-24.9

SUSE LE 11 SP4: new kernel-rt packages (20/04/2016).
New packages are available:
  SUSE LE 11 SP4: kernel-rt 3.0.101.rt130-51.1

SUSE LE 11 SP4: new xen packages (05/04/2016).
New packages are available:
  SUSE LE 11 SP4: xen 4.4.4_02-32.1

SUSE LE 12: new kernel packages.
New packages are available:
  SUSE LE 12 RTM: kernel 3.12.51-52.34.1

SUSE LE 12: new xen packages.
New packages are available:
  SUSE LE 12 RTM: xen 4.4.4_02-22.19.1

SUSE LE 12 SP1: new kernel packages (26/02/2016).
New packages are available:
  SUSE LE 12 SP1: kernel 3.12.53-60.30.1

SUSE LE 12 SP1: new kernel-rt packages.
New packages are available:
  SUSE LE 12 SP1: kernel-rt 3.12.58-14.1

SUSE LE 12 SP1: new xen packages.
New packages are available:
  SUSE LE 12 SP1: xen 4.5.2_06-7.1

Ubuntu: new linux-image-3.2.0-1476-omap4 packages.
New packages are available:
  Ubuntu 12.04 LTS: linux-image-3.2.0-1476-omap4 3.2.0-1476.99

Ubuntu: new linux-image-3.2.0-98-generic packages.
New packages are available:
  Ubuntu 12.04 LTS: linux-image-3.2.0-98-generic 3.2.0-98.138

Ubuntu: new linux-image packages.
New packages are available:
  Ubuntu 12.04 LTS: linux-image-3.2.0-97-generic 3.2.0-97.137
  Ubuntu 14.04 LTS: linux-image-3.13.0-74-generic 3.13.0-74.118, linux-image-3.16.0-57-generic 3.16.0-57.77~14.04.1, linux-image-3.19.0-42-generic 3.19.0-42.48~14.04.1, linux-image-4.2.0-22-generic 4.2.0-22.27~14.04.1
  Ubuntu 15.04: linux-image-3.19.0-42-generic 3.19.0-42.48
  Ubuntu 15.10: linux-image-4.2.0-22-generic 4.2.0-22.27, linux-image-4.2.0-1017-raspi2 4.2.0-1017.24

Ubuntu: new qemu-system packages.
New packages are available:
  Ubuntu 15.10: qemu-system 1:2.3+dfsg-5ubuntu9.2
  Ubuntu 14.04 LTS: qemu-system 2.0.0+dfsg-2ubuntu1.22
  Ubuntu 12.04 LTS: qemu-kvm 1.0+noroms-0ubuntu14.27
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides application vulnerability bulletins. The technology watch team tracks security threats targeting the computer system.