The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of Linux kernel: buffer overflow via macsec skb_to_sgvec

Synthesis of the vulnerability 

An attacker can generate a buffer overflow via macsec skb_to_sgvec() on the Linux kernel, in order to trigger a denial of service, and possibly to run code.
Vulnerable products: Fedora, Linux, RHEL, Ubuntu.
Severity of this weakness: 2/4.
Creation date: 25/04/2017.
Références of this bulletin: CERTFR-2017-AVI-158, CVE-2017-7477, FEDORA-2017-0aa0f69e0c, FEDORA-2017-17d1c05236, RHSA-2017:1615-01, RHSA-2017:1616-01, USN-3292-1, USN-3292-2, USN-3293-1, VIGILANCE-VUL-22548.

Description of the vulnerability 

An attacker can generate a buffer overflow via macsec skb_to_sgvec() on the Linux kernel, in order to trigger a denial of service, and possibly to run code.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This cybersecurity vulnerability impacts software or systems such as Fedora, Linux, RHEL, Ubuntu.

Our Vigil@nce team determined that the severity of this vulnerability is medium.

The trust level is of type confirmed by the editor, with an origin of intranet client.

An attacker with a expert ability can exploit this weakness alert.

Solutions for this threat 

Linux kernel: version 4.10.14.
The version 4.10.14 is fixed:
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Linux kernel: version 4.9.26.
The version 4.9.26 is fixed:
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Linux kernel: patch for macsec skb_to_sgvec.
A patch is indicated in information sources.

Fedora 24: new kernel packages.
New packages are available:
  Fedora 24: kernel 4.10.13-100.fc24

Fedora 25: new kernel packages.
New packages are available:
  Fedora 25: kernel 4.10.13-200.fc25

RHEL 7: new kernel packages.
New packages are available:
  RHEL 7: kernel 3.10.0-514.26.1.el7

RHEL 7: new kernel-rt packages.
New packages are available:
  RHEL 7: kernel-rt 3.10.0-514.26.1.rt56.442.el7

Ubuntu 16.10: new linux-image-generic packages.
New packages are available:
  Ubuntu 16.04 LTS: linux-image-4.8.0-52-generic 4.8.0-52.55~16.04.1
  Ubuntu 16.10: linux-image-generic 4.8.0.52.64

Ubuntu 17.04: new linux-image-generic packages.
New packages are available:
  Ubuntu 17.04: linux-image-generic 4.10.0.21.23
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides an applications vulnerabilities database. The Vigil@nce security watch publishes vulnerability bulletins about threats impacting the information system.