The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of Linux kernel: denial of service via TCP SACK Low MSS Resource

Synthesis of the vulnerability 

An attacker can trigger a fatal error via TCP SACK Low MSS Resource of the Linux kernel, in order to trigger a denial of service.
Vulnerable systems: Blue Coat CAS, Broadcom Content Analysis, GAiA, CheckPoint Security Gateway, Debian, BIG-IP Hardware, TMOS, Fedora, FortiAnalyzer, FortiAnalyzer Virtual Appliance, FortiGate, FortiGate Virtual Appliance, FortiOS, Android OS, QRadar SIEM, Tivoli Storage Manager, Linux, McAfee Email Gateway, McAfee NSP, McAfee NTBA, McAfee Web Gateway, openSUSE Leap, Oracle Communications, Panorama by Palo Alto, PAN-OS, Pulse Connect Secure, RHEL, RSA Authentication Manager, ROX, RuggedSwitch, SIMATIC, SUSE Linux Enterprise Desktop, SLES, Synology DSM, Ubuntu.
Severity of this threat: 3/4.
Creation date: 18/06/2019.
Références of this weakness: 1074268, CERTFR-2019-AVI-277, CERTFR-2019-AVI-278, CERTFR-2019-AVI-298, CERTFR-2019-AVI-300, CERTFR-2019-AVI-429, CERTFR-2019-AVI-458, CERTFR-2019-AVI-597, cpujan2020, CVE-2019-11479, DLA-1823-1, DLA-1824-1, DSA-2019-117, DSA-4465-1, FEDORA-2019-6c3d89b3d0, FEDORA-2019-914542e05c, FG-IR-19-180, K35421172, openSUSE-SU-2019:1570-1, openSUSE-SU-2019:1571-1, openSUSE-SU-2019:1579-1, PAN-SA-2019-0013, RHSA-2019:1479-01, RHSA-2019:1480-01, RHSA-2019:1481-01, RHSA-2019:1482-01, RHSA-2019:1483-01, RHSA-2019:1484-01, RHSA-2019:1485-01, RHSA-2019:1486-01, RHSA-2019:1487-01, RHSA-2019:1488-01, RHSA-2019:1489-01, RHSA-2019:1490-01, RHSA-2019:1602-01, SA44193, SB10287, sk156192, SSA-462066, SSB-439005, SUSE-SU-2019:14089-1, SUSE-SU-2019:1527-1, SUSE-SU-2019:1529-1, SUSE-SU-2019:1530-1, SUSE-SU-2019:1532-1, SUSE-SU-2019:1533-1, SUSE-SU-2019:1534-1, SUSE-SU-2019:1535-1, SUSE-SU-2019:1536-1, SUSE-SU-2019:1550-1, SUSE-SU-2019:1692-1, SUSE-SU-2019:2430-1, SYMSA1492, Synology-SA-19:28, USN-4041-1, USN-4041-2, VIGILANCE-VUL-29546, VU#905115.

Description of the vulnerability 

An attacker can trigger a fatal error via TCP SACK Low MSS Resource of the Linux kernel, in order to trigger a denial of service.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This cybersecurity threat impacts software or systems such as Blue Coat CAS, Broadcom Content Analysis, GAiA, CheckPoint Security Gateway, Debian, BIG-IP Hardware, TMOS, Fedora, FortiAnalyzer, FortiAnalyzer Virtual Appliance, FortiGate, FortiGate Virtual Appliance, FortiOS, Android OS, QRadar SIEM, Tivoli Storage Manager, Linux, McAfee Email Gateway, McAfee NSP, McAfee NTBA, McAfee Web Gateway, openSUSE Leap, Oracle Communications, Panorama by Palo Alto, PAN-OS, Pulse Connect Secure, RHEL, RSA Authentication Manager, ROX, RuggedSwitch, SIMATIC, SUSE Linux Enterprise Desktop, SLES, Synology DSM, Ubuntu.

Our Vigil@nce team determined that the severity of this computer threat note is important.

The trust level is of type confirmed by the editor, with an origin of internet client.

An attacker with a expert ability can exploit this security threat.

Solutions for this threat 

Linux kernel: version 5.1.11.
The version 5.1.11 is fixed:
  https://cdn.kernel.org/pub/linux/kernel/v5.x/

Linux kernel: version 4.19.52.
The version 4.19.52 is fixed:
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Linux kernel: version 4.14.127.
The version 4.14.127 is fixed:
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Linux kernel: version 4.9.182.
The version 4.9.182 is fixed:
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Linux kernel: version 4.4.182.
The version 4.4.182 is fixed:
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Linux kernel: version 3.16.69.
The version 3.16.69 is fixed:
  https://cdn.kernel.org/pub/linux/kernel/v3.x/

Linux kernel: patch for TCP SACK Low MSS Resource.
A patch is indicated in information sources.

Linux kernel: workaround for TCP SACK Low MSS Resource.
A workaround is indicated in the information source.

Check Point: solution for Linux Kernel.
The solution is indicated in information sources.

Debian 8: new linux packages.
New packages are available:
  Debian 8: linux 3.16.68-2

Debian 9: new linux-4.9 packages.
New packages are available:
  Debian 8: linux-4.9 4.9.168-1+deb9u3~deb8u1

Debian 9: new linux packages.
New packages are available:
  Debian 9: linux 4.9.168-1+deb9u3

Fedora: new kernel-headers packages.
New packages are available:
  Fedora 29: kernel-headers 5.1.11-200.fc29
  Fedora 30: kernel-headers 5.1.11-300.fc30

Fedora: new kernel packages.
New packages are available:
  Fedora 29: kernel 5.1.11-200.fc29
  Fedora 30: kernel 5.1.11-300.fc30

FortiAnalyzer, FortiGate: solution for Linux Kernel.
The solution is indicated in information sources.

Google Android/Pixel: patch for March 2020.
A patch is indicated in information sources.

IBM QRadar SIEM: patch for Linux.
A patch is available:
  IBM Security QRadar Packet Capture 7.2.0 - 7.2.8 Patch 4: https://www-945.ibm.com/support/fixcentral/swg/downloadFixes?parent=IBM%20Security&product=ibm/Other+software/IBM+QRadar+Network+Packet+Capture+Appliance&release=All&platform=All&function=fixId&fixids=7.2.8-QRadar-NETPCAP-Upgrade-60&includeRequisites=1&includeSupersedes=0&downloadMethod=ddp
  IBM Security QRadar Packet Capture 7.3.0 - 7.3.2 Patch 1: https://www-945.ibm.com/support/fixcentral/swg/downloadFixes?parent=IBM%20Security&product=ibm/Other+software/IBM+QRadar+Network+Packet+Capture+Appliance&release=All&platform=All&function=fixId&fixids=7.3.2-QRadar-NETPCAP-Upgrade-5019&includeRequisites=1&includeSupersedes=0&downloadMethod=ddp

IBM Spectrum Protect Plus: version 10.1.4.222.
The version 10.1.4.222 is fixed:
  http://www.ibm.com/support/docview.wss?uid=ibm10880861

McAfee: solution for TCP SACK.
The solution is indicated in information sources.

openSUSE Leap 15.0: new kernel packages.
New packages are available:
  openSUSE Leap 15.0: kernel 4.12.14-lp150.12.64.1

openSUSE Leap 15.1: new kernel packages.
New packages are available:
  openSUSE Leap 15.1: kernel 4.12.14-lp151.28.7.1

openSUSE Leap 42.3: new kernel packages.
New packages are available:
  openSUSE Leap 42.3: kernel 4.4.180-102.1

Oracle Communications: CPU of January 2020.
A Critical Patch Update is available:
  https://support.oracle.com/rs?type=doc&id=2625594.1
  https://support.oracle.com/rs?type=doc&id=2626101.1
  https://support.oracle.com/rs?type=doc&id=2628576.1
  https://support.oracle.com/rs?type=doc&id=2626102.1
  https://support.oracle.com/rs?type=doc&id=2622427.1
  https://support.oracle.com/rs?type=doc&id=2595443.1
  https://support.oracle.com/rs?type=doc&id=2595442.1
  https://support.oracle.com/rs?type=doc&id=2617852.1
  https://support.oracle.com/rs?type=doc&id=2626103.1

PAN-OS: fixed versions for TCP SACK.
Fixed versions are indicated in information sources.

Pulse Connect Secure: fixed versions for TCP SACK.
Fixed versions are indicated in information sources.

RHEL 6.5: new kernel packages.
New packages are available:
  RHEL 6: kernel 2.6.32-431.95.3.el6

RHEL 6.6: new kernel packages.
New packages are available:
  RHEL 6: kernel 2.6.32-504.79.3.el6

RHEL 6: new kernel packages.
New packages are available:
  RHEL 6: kernel 2.6.32-754.15.3.el6

RHEL 6: new kernel-rt packages.
New packages are available:
  RHEL 6: kernel-rt 3.10.0-693.50.3.rt56.644.el6rt

RHEL 7.2: new kernel packages.
New packages are available:
  RHEL 7: kernel 3.10.0-327.79.2.el7

RHEL 7.3: new kernel packages.
New packages are available:
  RHEL 7: kernel 3.10.0-514.66.2.el7

RHEL 7.4: new kernel packages.
New packages are available:
  RHEL 7: kernel 3.10.0-693.50.3.el7

RHEL 7.5: new kernel packages.
New packages are available:
  RHEL 7: kernel 3.10.0-862.34.2.el7

RHEL 7: new kernel-alt packages.
New packages are available:
  RHEL 7: kernel-alt 4.14.0-115.8.2.el7a

RHEL 7: new kernel packages.
New packages are available:
  RHEL 7: kernel 3.10.0-957.21.3.el7

RHEL 7: new kernel-rt packages.
New packages are available:
  RHEL 7: kernel-rt 3.10.0-957.21.3.rt56.935.el7

RHEL 8.0: new kernel packages.
New packages are available:
  RHEL 8: kernel 4.18.0-80.4.2.el8_0

RHEL 8.0: new kernel-rt packages.
New packages are available:
  RHEL 8: kernel-rt 4.18.0-80.4.2.rt9.152.el8_0

RSA Authentication Manager: version 8.4 Patch 5.
The version 8.4 Patch 5 is fixed:
  https://www.dell.com/support/

Siemens: solution for TCP SACK.
The solution is indicated in information sources.

SIMATIC S7-1500 CPU 1518: workaround for GNU/Linux Vulnerabilities.
A workaround is indicated in the information source.

SUSE LE 11 SP4: new kernel packages.
New packages are available:
  SUSE LE 11 SP4: kernel 3.0.101-108.95.2

SUSE LE 12 RTM: new kernel packages.
New packages are available:
  SUSE LE 12 RTM: kernel 3.12.61-52.154.1

SUSE LE 12 SP1: new kernel packages (18/06/2019).
New packages are available:
  SUSE LE 12 SP1: kernel 3.12.74-60.64.115.1

SUSE LE 12 SP2: new kernel packages.
New packages are available:
  SUSE LE 12 SP2: kernel 4.4.121-92.114.1

SUSE LE 12 SP3: new kernel packages.
New packages are available:
  SUSE LE 12 SP3: kernel 4.4.180-94.97.1

SUSE LE 12 SP4: new kernel packages (18/06/2019).
New packages are available:
  SUSE LE 12 SP4: kernel 4.12.14-95.19.1

SUSE LE 15: new kernel packages.
New packages are available:
  SUSE LE 15 RTM: kernel 4.12.14-150.22.1

SUSE LE 15 SP1: new kernel packages.
New packages are available:
  SUSE LE 15 SP1: kernel 4.12.14-197.4.1

SUSE LE 15 SP1: new kernel-source-rt packages.
New packages are available:
  SUSE LE 15 SP1: kernel-source-rt 4.12.14-14.8.1

Ubuntu: new linux-image packages.
New packages are available:
  Ubuntu 14.04 ESM: linux-image-generic-lts-xenial 4.4.0.154.135
  Ubuntu 16.04 LTS: linux-image-generic 4.4.0.154.162
  Ubuntu 18.04 LTS: linux-image-generic 4.15.0.54.56
  Ubuntu 18.10: linux-image-generic 4.18.0.25.26
  Ubuntu 19.04: linux-image-generic 5.0.0.20.21

Wind River Linux: version 10.18.44.9.
The version 10.18.44.9 is fixed:
  https://support2.windriver.com/
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides computer security announces. The Vigil@nce computer vulnerability tracking service alerts your teams of vulnerabilities or threats impacting your information system.