The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of Linux kernel: denial of service via kmem_cache_alloc_bulk

Synthesis of the vulnerability 

An attacker can trigger a fatal error via kmem_cache_alloc_bulk() of the Linux kernel, in order to trigger a denial of service.
Impacted software: Linux, openSUSE Leap, SLES.
Severity of this computer vulnerability: 1/4.
Creation date: 11/11/2020.
Références of this announce: CERTFR-2021-AVI-021, CERTFR-2021-AVI-035, CVE-2020-29370, openSUSE-SU-2021:0242-1, PROJ-ZERO-2022, SUSE-SU-2021:0096-1, SUSE-SU-2021:0108-1, SUSE-SU-2021:0117-1, VIGILANCE-VUL-33886.

Description of the vulnerability 

An attacker can trigger a fatal error via kmem_cache_alloc_bulk() of the Linux kernel, in order to trigger a denial of service.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This weakness note impacts software or systems such as Linux, openSUSE Leap, SLES.

Our Vigil@nce team determined that the severity of this threat note is low.

The trust level is of type confirmed by the editor, with an origin of user shell.

An attacker with a expert ability can exploit this computer weakness.

Solutions for this threat 

Linux kernel: version 5.5.11.
The version 5.5.11 is fixed:
  https://cdn.kernel.org/pub/linux/kernel/v5.x/

Linux kernel: version 5.4.27.
The version 5.4.27 is fixed:
  https://cdn.kernel.org/pub/linux/kernel/v5.x/

Linux kernel: version 4.19.112.
The version 4.19.112 is fixed:
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Linux kernel: version 4.14.174.
The version 4.14.174 is fixed:
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Linux kernel: version 4.9.217.
The version 4.9.217 is fixed:
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Linux kernel: version 4.4.217.
The version 4.4.217 is fixed:
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Linux kernel: patch for kmem_cache_alloc_bulk.
A patch is indicated in information sources.

openSUSE Leap 15.2: new kernel packages (15/01/2021).
New packages are available:
  openSUSE Leap 15.2: kernel 5.3.18-lp152.60.1

openSUSE Leap 15.2: new kernel-rt packages.
New packages are available:
  openSUSE Leap 15.2: kernel-rt 5.3.18-lp152.3.5.1

SUSE LE 15 SP2: new kernel-azure packages.
New packages are available:
  SUSE LE 15 SP2: kernel-azure 5.3.18-18.32.1

SUSE LE 15 SP2: new kernel packages (14/01/2021).
New packages are available:
  SUSE LE 15 SP2: kernel 5.3.18-24.46.1

SUSE LE 15 SP2: new kernel-rt packages (13/01/2021).
New packages are available:
  SUSE LE 15 SP2: kernel-rt 5.3.18-22.1
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides a software vulnerabilities alert. The Vigil@nce team tracks computer vulnerabilities impacting systems and applications.