The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of Linux kernel: denial of service via n_tty_receive_char_special

Synthesis of the vulnerability 

An attacker can trigger a fatal error via n_tty_receive_char_special() of the Linux kernel, in order to trigger a denial of service.
Impacted systems: Linux, SUSE Linux Enterprise Desktop, SLES.
Severity of this alert: 1/4.
Creation date: 16/04/2021.
Références of this alert: 1184397, CERTFR-2021-AVI-278, CERTFR-2021-AVI-284, CERTFR-2021-AVI-302, CERTFR-2021-AVI-387, CERTFR-2021-AVI-392, CVE-2021-20219, SUSE-SU-2021:1210-1, SUSE-SU-2021:1248-1, SUSE-SU-2021:1266-1, SUSE-SU-2021:1573-1, SUSE-SU-2021:1596-1, SUSE-SU-2021:1617-1, SUSE-SU-2021:1623-1, SUSE-SU-2021:1624-1, VIGILANCE-VUL-35093.

Description of the vulnerability 

An attacker can trigger a fatal error via n_tty_receive_char_special() of the Linux kernel, in order to trigger a denial of service.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This computer threat note impacts software or systems such as Linux, SUSE Linux Enterprise Desktop, SLES.

Our Vigil@nce team determined that the severity of this weakness alert is low.

The trust level is of type confirmed by the editor, with an origin of user shell.

An attacker with a expert ability can exploit this computer weakness note.

Solutions for this threat 

Linux kernel: version 4.4.140.
The version 4.4.140 is fixed:
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Linux kernel: version 3.18.115.
The version 3.18.115 is fixed:
  https://cdn.kernel.org/pub/linux/kernel/v3.x/

Linux kernel: patch for n_tty_receive_char_special.
A patch is indicated in information sources.

SUSE LE 12 SP2: new kernel packages.
New packages are available:
  SUSE LE 12 SP2: kernel 4.4.121-92.155.1

SUSE LE 12 SP3: new kernel packages.
New packages are available:
  SUSE LE 12 SP3: kernel 4.4.180-94.144.1

SUSE LE 12 SP4: new kernel packages.
New packages are available:
  SUSE LE 12 SP4: kernel 4.12.14-95.74.1

SUSE LE 12 SP5: new kernel-azure packages.
New packages are available:
  SUSE LE 12 SP5: kernel-azure 4.12.14-16.53.1

SUSE LE 12 SP5: new kernel packages (16/04/2021).
New packages are available:
  SUSE LE 12 SP5: kernel 4.12.14-122.66.2

SUSE LE 12 SP5: new kernel-rt packages.
New packages are available:
  SUSE LE 12 SP5: kernel-rt 4.12.14-10.40.1

SUSE LE 15 RTM: new kernel packages.
New packages are available:
  SUSE LE 15 RTM: kernel 4.12.14-150.72.1

SUSE LE 15 SP1: new kernel packages (18/05/2021).
New packages are available:
  SUSE LE 15 SP1: kernel 4.12.14-197.89.2
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides application vulnerability analysis. The Vigil@nce computer vulnerability tracking service alerts your teams of vulnerabilities or threats impacting your information system.