The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of Linux kernel: information disclosure via romfs_dev_read

Synthesis of the vulnerability 

A local attacker can read a memory fragment via romfs_dev_read() of the Linux kernel, in order to obtain sensitive information.
Vulnerable software: Linux, openSUSE Leap, SUSE Linux Enterprise Desktop, SLES.
Severity of this announce: 1/4.
Creation date: 02/10/2020.
Références of this computer vulnerability: CERTFR-2020-AVI-794, CERTFR-2020-AVI-811, CERTFR-2020-AVI-837, CERTFR-2021-AVI-021, CVE-2020-29371, openSUSE-SU-2020:2161-1, openSUSE-SU-2020:2193-1, openSUSE-SU-2020:2260-1, PROJ-ZERO-2077, SUSE-SU-2020:3713-1, SUSE-SU-2020:3717-1, SUSE-SU-2020:3718-1, SUSE-SU-2020:3748-1, SUSE-SU-2020:3764-1, SUSE-SU-2020:3766-1, SUSE-SU-2020:3798-1, SUSE-SU-2021:0097-1, SUSE-SU-2021:0098-1, VIGILANCE-VUL-33475.

Description of the vulnerability 

A local attacker can read a memory fragment via romfs_dev_read() of the Linux kernel, in order to obtain sensitive information.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This computer vulnerability alert impacts software or systems such as Linux, openSUSE Leap, SUSE Linux Enterprise Desktop, SLES.

Our Vigil@nce team determined that the severity of this computer threat alert is low.

The trust level is of type confirmed by the editor, with an origin of user shell.

A proof of concept or an attack tool is available, so your teams have to process this alert. An attacker with a technician ability can exploit this security vulnerability.

Solutions for this threat 

Linux kernel: version 5.8.4.
The version 5.8.4 is fixed:
  https://cdn.kernel.org/pub/linux/kernel/v5.x/

Linux kernel: version 5.7.18.
The version 5.7.18 is fixed:
  https://cdn.kernel.org/pub/linux/kernel/v5.x/

Linux kernel: version 5.4.61.
The version 5.4.61 is fixed:
  https://cdn.kernel.org/pub/linux/kernel/v5.x/

Linux kernel: version 4.19.142.
The version 4.19.142 is fixed:
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Linux kernel: version 4.14.195.
The version 4.14.195 is fixed:
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Linux kernel: version 4.9.234.
The version 4.9.234 is fixed:
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Linux kernel: version 4.4.234.
The version 4.4.234 is fixed:
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Linux kernel: patch for romfs_dev_read.
A patch is indicated in information sources.

openSUSE Leap 15.1: new kernel packages (07/12/2020).
New packages are available:
  openSUSE Leap 15.1: kernel 4.12.14-lp151.28.87.1

openSUSE Leap 15.2: new kernel packages (07/12/2020).
New packages are available:
  openSUSE Leap 15.2: kernel 5.3.18-lp152.54.1

openSUSE Leap 15.2: new kernel packages (15/12/2020).
New packages are available:
  openSUSE Leap 15.2: kernel 5.3.18-lp152.57.1.lp152.8.17.1

SUSE LE 12 SP5: new kernel-azure packages (13/01/2021).
New packages are available:
  SUSE LE 12 SP5: kernel-azure 4.12.14-16.41.1

SUSE LE 12 SP5: new kernel packages (09/12/2020).
New packages are available:
  SUSE LE 12 SP5: kernel 4.12.14-122.54.1

SUSE LE 12 SP5: new kernel-rt packages (14/12/2020).
New packages are available:
  SUSE LE 12 SP5: kernel-rt 4.12.14-10.25.1

SUSE LE 15 SP1: new kernel-azure packages (13/01/2021).
New packages are available:
  SUSE LE 15 SP1: kernel-azure 4.12.14-8.58.1

SUSE LE 15 SP1: new kernel packages (09/12/2020).
New packages are available:
  SUSE LE 15 SP1: kernel 4.12.14-197.75.1

SUSE LE 15 SP1: new kernel-rt packages (15/12/2020).
New packages are available:
  SUSE LE 15 SP1: kernel-rt 4.12.14-14.44.2

SUSE LE 15 SP2: new kernel-azure packages.
New packages are available:
  SUSE LE 15 SP2: kernel-azure 5.3.18-18.29.1

SUSE LE 15 SP2: new kernel packages (11/12/2020).
New packages are available:
  SUSE LE 15 SP2: kernel 5.3.18-24.43.2

SUSE LE 15 SP2: new kernel-rt packages (14/12/2020).
New packages are available:
  SUSE LE 15 SP2: kernel-rt 5.3.18-19.1
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides software vulnerabilities alerts. Each administrator can customize the list of products for which he wants to receive vulnerability alerts.