The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of Linux kernel: integer overflow via SO_SND/RCVBUFFORCE

Synthesis of the vulnerability 

An attacker with the CAP_NET_ADMIN capability can generate an integer overflow via SO_SNDBUFFORCE/SO_RCVBUFFORCE on the Linux kernel, in order to trigger a denial of service, and possibly to run code.
Vulnerable software: Debian, Fedora, Android OS, Linux, openSUSE Leap, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Severity of this announce: 1/4.
Creation date: 05/12/2016.
Revision date: 15/05/2017.
Références of this computer vulnerability: CERTFR-2017-AVI-004, CERTFR-2017-AVI-016, CERTFR-2017-AVI-034, CERTFR-2017-AVI-042, CERTFR-2017-AVI-044, CERTFR-2017-AVI-050, CERTFR-2017-AVI-053, CERTFR-2017-AVI-054, CERTFR-2017-AVI-131, CVE-2016-9793, DLA-772-1, FEDORA-2016-107f03cc00, FEDORA-2016-5aff4a6bbc, FEDORA-2016-5cb5b4082d, openSUSE-SU-2017:0456-1, openSUSE-SU-2017:0458-1, RHSA-2017:0931-01, RHSA-2017:0933-01, SUSE-SU-2017:0181-1, SUSE-SU-2017:0333-1, SUSE-SU-2017:0407-1, SUSE-SU-2017:0437-1, SUSE-SU-2017:0464-1, SUSE-SU-2017:0471-1, SUSE-SU-2017:0494-1, SUSE-SU-2017:1102-1, USN-3168-1, USN-3168-2, USN-3169-1, USN-3169-2, USN-3169-3, USN-3169-4, USN-3170-1, USN-3170-2, VIGILANCE-VUL-21259.

Description of the vulnerability 

An attacker with the CAP_NET_ADMIN capability can generate an integer overflow via SO_SNDBUFFORCE/SO_RCVBUFFORCE on the Linux kernel, in order to trigger a denial of service, and possibly to run code.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This security note impacts software or systems such as Debian, Fedora, Android OS, Linux, openSUSE Leap, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Our Vigil@nce team determined that the severity of this threat announce is low.

The trust level is of type confirmed by the editor, with an origin of privileged shell.

A proof of concept or an attack tool is available, so your teams have to process this alert. An attacker with a technician ability can exploit this computer weakness announce.

Solutions for this threat 

Linux kernel: version 4.8.14.
The version 4.8.14 is fixed:
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Linux kernel: version 4.4.38.
The version 4.4.38 is fixed:
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Linux kernel: version 4.1.50.
The version 4.1.50 is fixed:
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Linux kernel: version 3.18.52.
The version 3.18.52 is fixed:
  https://cdn.kernel.org/pub/linux/kernel/v3.x/

Linux kernel: version 3.16.40.
The version 3.16.40 is fixed:
  https://cdn.kernel.org/pub/linux/kernel/v3.x/

Linux kernel: version 3.12.69.
The version 3.12.69 is fixed:
  https://cdn.kernel.org/pub/linux/kernel/v3.x/

Linux kernel: version 3.2.85.
The version 3.2.85 is fixed:
  https://cdn.kernel.org/pub/linux/kernel/v3.x/

Linux kernel: patch for SO_SND/RCVBUFFORCE.
A patch is indicated in information sources.

Android OS: patch 2017-03-01 and 2017-03-05.
A patch is indicated in information sources.

Debian 7: new linux packages.
New packages are available:
  Debian 7: linux 3.2.84-1

Fedora: new kernel packages.
New packages are available:
  Fedora 23: kernel 4.8.13-100.fc23
  Fedora 24: kernel 4.8.13-200.fc24
  Fedora 25: kernel 4.8.13-300.fc25

openSUSE Leap 42.1: new kernel packages.
New packages are available:
  openSUSE Leap 42.1: kernel 4.1.38-47.1

openSUSE Leap 42.2: new kernel packages.
New packages are available:
  openSUSE Leap 42.2: kernel 4.4.46-11.1

RHEL 7: new kernel packages.
New packages are available:
  RHEL 7: kernel 3.10.0-514.16.1.el7

RHEL 7: new kernel-rt packages.
New packages are available:
  RHEL 7: kernel-rt 3.10.0-514.16.1.rt56.437.el7

SUSE LE 11 SP2: new kernel packages (31/01/2017).
New packages are available:
  SUSE LE 11 SP2: kernel 3.0.101-0.7.53.1

SUSE LE 11 SP3: new kernel packages.
New packages are available:
  SUSE LE 11 SP3: kernel 3.0.101-0.47.96.1

SUSE LE 11 SP4: new kernel packages (10/02/2017).
New packages are available:
  SUSE LE 11 SP4: kernel 3.0.101-94.1

SUSE LE 11 SP4: new kernel-rt packages (26/04/2017).
New packages are available:
  SUSE LE 11 SP4: kernel-rt 3.0.101.rt130-68.1

SUSE LE 12 RTM: new kernel packages.
New packages are available:
  SUSE LE 12 RTM: kernel 3.12.61-52.66.1

SUSE LE 12 SP1: new kernel packages.
New packages are available:
  SUSE LE 12 SP1: kernel 3.12.69-60.64.29.1

SUSE LE 12 SP1: new kernel-rt packages.
New packages are available:
  SUSE LE 12 SP1: kernel-rt 3.12.69-60.30.1

SUSE LE 12 SP2: new kernel packages.
New packages are available:
  SUSE LE 12 SP2: kernel-default 4.4.38-93.1

Ubuntu: new linux-image-3.13.0 packages.
New packages are available:
  Ubuntu 14.04 LTS: linux-image-3.13.0-107-generic 3.13.0-107.154
  Ubuntu 12.04 LTS: linux-image-3.13.0-107-generic 3.13.0-107.154~precise1

Ubuntu: new linux-image-4.4.0 packages.
New packages are available:
  Ubuntu 14.04 LTS: linux-image-4.4.0-59-generic 4.4.0-59.80~14.04.1
  Ubuntu 16.04 LTS: linux-image-4.4.0-59-generic 4.4.0-59.80, linux-image-4.4.0-1040-raspi2 4.4.0-1040.47, linux-image-4.4.0-1044-snapdragon 4.4.0-1044.48

Ubuntu: new linux-image-4.8.0 packages.
New packages are available:
  Ubuntu 16.10: linux-image-4.8.0-34-generic 4.8.0-34.36, linux-image-4.8.0-1022-raspi2 4.8.0-1022.25
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides a networks vulnerabilities bulletin. The Vigil@nce team tracks computer vulnerabilities impacting systems and applications.