The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of Linux kernel: integer overflow via alarm_timer_nsleep

Synthesis of the vulnerability 

An attacker can generate an integer overflow via alarm_timer_nsleep() of the Linux kernel, in order to trigger a denial of service, and possibly to run code.
Vulnerable software: Debian, Fedora, QRadar SIEM, Linux, openSUSE Leap, RHEL, SIMATIC, Slackware, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Severity of this announce: 2/4.
Creation date: 03/07/2018.
Références of this computer vulnerability: 1103505, CERTFR-2018-AVI-358, CERTFR-2018-AVI-365, CERTFR-2018-AVI-392, CERTFR-2018-AVI-426, CERTFR-2018-AVI-557, CERTFR-2019-AVI-183, CERTFR-2019-AVI-391, CERTFR-2019-AVI-419, CVE-2018-13053, DLA-1715-1, DLA-1731-1, DLA-1731-2, FEDORA-2018-50075276e8, openSUSE-SU-2018:2118-1, openSUSE-SU-2018:2119-1, RHSA-2019:0831-01, RHSA-2019:2029-01, RHSA-2019:2043-01, SSA:2019-030-01, SSB-439005, SUSE-SU-2018:2051-1, SUSE-SU-2018:2150-1, SUSE-SU-2018:2332-1, SUSE-SU-2018:2344-1, SUSE-SU-2018:2362-1, SUSE-SU-2018:2366-1, SUSE-SU-2018:2384-1, SUSE-SU-2018:2637-1, USN-3821-1, USN-3821-2, USN-4094-1, USN-4118-1, VIGILANCE-VUL-26605.

Description of the vulnerability 

An attacker can generate an integer overflow via alarm_timer_nsleep() of the Linux kernel, in order to trigger a denial of service, and possibly to run code.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This threat impacts software or systems such as Debian, Fedora, QRadar SIEM, Linux, openSUSE Leap, RHEL, SIMATIC, Slackware, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Our Vigil@nce team determined that the severity of this computer threat is medium.

The trust level is of type confirmed by the editor, with an origin of user shell.

An attacker with a expert ability can exploit this cybersecurity bulletin.

Solutions for this threat 

Linux kernel: version 4.18.12.
The version 4.18.12 is fixed:
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Linux kernel: version 4.14.74.
The version 4.14.74 is fixed:
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Linux kernel: version 4.9.131.
The version 4.9.131 is fixed:
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Linux kernel: version 4.4.160.
The version 4.4.160 is fixed:
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Linux kernel: version 3.18.124.
The version 3.18.124 is fixed:
  https://cdn.kernel.org/pub/linux/kernel/v3.x/

Linux kernel: version 3.16.62.
The version 3.16.62 is fixed:
  https://cdn.kernel.org/pub/linux/kernel/v3.x/

Linux kernel: patch for alarm_timer_nsleep.
A patch is indicated in information sources.

Debian 8: new linux-4.9 packages.
New packages are available:
  Debian 8: linux-4.9 4.9.144-3.1~deb8u1

Debian 8: new linux packages (27/03/2019).
New packages are available:
  Debian 8: linux 3.16.64-2

Fedora 28: new kernel packages.
New packages are available:
  Fedora 28: kernel 4.17.5-200.fc28

IBM QRadar SIEM: patch for Kernel.
A patch is indicated in information sources.

openSUSE Leap 15.0: new kernel packages.
New packages are available:
  openSUSE Leap 15.0: kernel 4.12.14-lp150.12.7.1

openSUSE Leap 42.3: new kernel packages.
New packages are available:
  openSUSE Leap 42.3: kernel 4.4.140-62.2

RHEL 7: new kernel-alt packages.
New packages are available:
  RHEL 7: kernel-alt 4.14.0-115.7.1.el7a

RHEL 7: new kernel packages.
New packages are available:
  RHEL 7: kernel 3.10.0-1062.el7

RHEL 7: new kernel-rt packages.
New packages are available:
  RHEL 7: kernel-rt 3.10.0-1062.rt56.1022.el7

SIMATIC S7-1500 CPU 1518: workaround for GNU/Linux Vulnerabilities.
A workaround is indicated in the information source.

Slackware: new kernel packages.
New packages are available:
  Slackware 14.2: kernel 4.4.172-i586-1

SUSE LE 11 SP3: new kernel packages.
New packages are available:
  SUSE LE 11 SP3: kernel 3.0.101-0.47.106.43.1

SUSE LE 11 SP4: new kernel packages.
New packages are available:
  SUSE LE 11 SP4: kernel 3.0.101-108.68.1

SUSE LE 11 SP4: new kernel-rt packages.
New packages are available:
  SUSE LE 11 SP4: kernel-rt 3.0.101.rt130-69.33.1

SUSE LE 12 RTM: new kernel packages.
New packages are available:
  SUSE LE 12 RTM: kernel 3.12.61-52.141.1

SUSE LE 12 SP1: new kernel packages.
New packages are available:
  SUSE LE 12 SP1: kernel 3.12.74-60.64.99.1

SUSE LE 12 SP2: new kernel packages.
New packages are available:
  SUSE LE 12 SP2: kernel 4.4.121-92.92.1

SUSE LE 12 SP3: new kernel packages.
New packages are available:
  SUSE LE 12 SP3: kernel 4.4.140-94.42.1

SUSE LE 12 SP3: new kernel-rt packages.
New packages are available:
  SUSE LE 12 SP3: kernel-rt 4.4.139-3.17.1

Ubuntu 16/18: new linux-image-aws packages.
New packages are available:
  Ubuntu 16.04 LTS: linux-image-aws 4.15.0.1047.47
  Ubuntu 18.04 LTS: linux-image-aws 4.15.0.1047.46

Ubuntu: new linux-image-4.15.0 packages.
New packages are available:
  Ubuntu 16.04 LTS: linux-image-generic-hwe-16.04 4.15.0.58.79
  Ubuntu 18.04 LTS: linux-image-generic 4.15.0.58.60

Ubuntu: new linux-image-4.4.0-139-generic packages.
New packages are available:
  Ubuntu 16.04 LTS: linux-image-4.4.0-139-generic 4.4.0-139.165
  Ubuntu 14.04 LTS: linux-image-4.4.0-139-generic 4.4.0-139.165~14.04.1
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides application vulnerability alerts. The Vigil@nce vulnerability database contains several thousand vulnerabilities.