The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of Linux kernel: memory corruption via inotify_handle_event

Synthesis of the vulnerability 

An attacker can generate a memory corruption via inotify_handle_event() of the Linux kernel, in order to trigger a denial of service, and possibly to run code.
Vulnerable products: Debian, Fedora, Android OS, Linux, openSUSE Leap, RHEL, SUSE Linux Enterprise Desktop, SLES, Synology DSM, Synology DS***, Synology RS***, Ubuntu.
Severity of this weakness: 2/4.
Creation date: 03/08/2017.
Références of this bulletin: CERTFR-2017-AVI-247, CERTFR-2017-AVI-249, CERTFR-2017-AVI-267, CERTFR-2017-AVI-277, CERTFR-2017-AVI-282, CERTFR-2017-AVI-287, CERTFR-2017-AVI-288, CERTFR-2017-AVI-293, CERTFR-2017-AVI-310, CERTFR-2017-AVI-311, CERTFR-2017-AVI-337, CERTFR-2017-AVI-400, CVE-2017-7533, DSA-3927-1, FEDORA-2017-73f71456d7, FEDORA-2017-adc7d95627, FEDORA-2018-884a105c04, openSUSE-SU-2017:2110-1, openSUSE-SU-2017:2112-1, RHSA-2017:2473-01, RHSA-2017:2585-01, RHSA-2017:2669-01, RHSA-2017:2770-01, RHSA-2017:2869-01, SUSE-SU-2017:2041-1, SUSE-SU-2017:2042-1, SUSE-SU-2017:2074-1, SUSE-SU-2017:2286-1, SUSE-SU-2017:2342-1, SUSE-SU-2017:2389-1, SUSE-SU-2017:2525-1, SUSE-SU-2017:2956-1, Synology-SA-17:37, USN-3377-1, USN-3377-2, USN-3378-1, USN-3378-2, USN-3392-1, USN-3392-2, VIGILANCE-VUL-23448.

Description of the vulnerability 

An attacker can generate a memory corruption via inotify_handle_event() of the Linux kernel, in order to trigger a denial of service, and possibly to run code.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This cybersecurity weakness impacts software or systems such as Debian, Fedora, Android OS, Linux, openSUSE Leap, RHEL, SUSE Linux Enterprise Desktop, SLES, Synology DSM, Synology DS***, Synology RS***, Ubuntu.

Our Vigil@nce team determined that the severity of this security vulnerability is medium.

The trust level is of type confirmed by the editor, with an origin of user shell.

An attacker with a expert ability can exploit this vulnerability bulletin.

Solutions for this threat 

Linux kernel: version 4.12.5.
The version 4.12.5 is fixed:
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Linux kernel: version 4.9.41.
The version 4.9.41 is fixed:
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Linux kernel: version 4.4.80.
The version 4.4.80 is fixed:
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Linux kernel: version 3.18.64.
The version 3.18.64 is fixed:
  https://cdn.kernel.org/pub/linux/kernel/v3.x/

Linux kernel: version 3.16.47.
The version 3.16.47 is fixed:
  https://cdn.kernel.org/pub/linux/kernel/v3.x/

Linux kernel: patch for inotify_handle_event.
A patch is indicated in information sources.

Android OS: patches 2017-12-01 and 2017-12-05.
A patch is indicated in information sources.

Debian 9: new linux packages.
New packages are available:
  Debian 9: linux 4.9.30-2+deb9u3

Fedora 25: new kernel packages.
New packages are available:
  Fedora 25: kernel 4.12.8-200.fc25

Fedora 26: new kernel packages (14/05/2018).
New packages are available:
  Fedora 26: kernel 4.16.7-100.fc26

Fedora 26: new kernel packages (16/08/2017).
New packages are available:
  Fedora 26: kernel 4.12.5-300.fc26

openSUSE Leap 42.2: new kernel packages.
New packages are available:
  openSUSE Leap 42.2: kernel 4.4.79-18.23.1

openSUSE Leap 42.3: new kernel packages.
New packages are available:
  openSUSE Leap 42.3: kernel 4.4.79-4.2

RHEL 6: new kernel-rt packages.
New packages are available:
  RHEL 6: kernel-rt 3.10.0-693.2.1.rt56.585.el6rt

RHEL 7: new kernel packages.
New packages are available:
  RHEL 7: kernel 3.10.0-693.1.1.el7

RHEL 7: new kernel-rt packages.
New packages are available:
  RHEL 7: kernel-rt 3.10.0-693.2.1.rt56.620.el7

SUSE LE 11 SP3: new kernel packages.
New packages are available:
  SUSE LE 11 SP3: kernel 3.0.101-0.47.106.5.1

SUSE LE 11 SP4: new kernel packages.
New packages are available:
  SUSE LE 11 SP4: kernel 3.0.101-108.7.1

SUSE LE 11 SP4: new kernel-rt packages (05/09/2017).
New packages are available:
  SUSE LE 11 SP4: kernel-rt 3.0.101.rt130-69.5.1

SUSE LE 12: new kernel packages.
New packages are available:
  SUSE LE 12 RTM: kernel 3.12.61-52.83.1
  SUSE LE 12 SP1: kernel 3.12.74-60.64.51.1
  SUSE LE 12 SP2: kernel 4.4.74-92.32.1

SUSE LE 12 SP2: new kernel-rt packages (09/11/2017).
New packages are available:
  SUSE LE 12 SP2: kernel-rt 4.4.88-18.1

SUSE LE 12 SP3: new kernel packages.
New packages are available:
  SUSE LE 12 SP3: kernel 4.4.82-6.3.1

Synology RS/DS: version 6.1.3-15152-3.
The version 6.1.3-15152-3 is fixed:
  https://www.synology.com/

Ubuntu: new linux-image-4.10.0 packages.
New packages are available:
  Ubuntu 16.04 LTS: linux-image-generic-hwe-16.04 4.10.0.30.33
  Ubuntu 17.04: linux-image-generic 4.10.0.30.31

Ubuntu: new linux-image-4.4.0 packages.
New packages are available:
  Ubuntu 14.04 LTS: linux-image-generic-lts-xenial 4.4.0-92.115~14.04.1
  Ubuntu 16.04 LTS: linux-image-generic 4.4.0.92.97
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides a computer security bulletin. Each administrator can customize the list of products for which he wants to receive vulnerability alerts.