The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of Linux kernel: out-of-bounds memory reading via ip6gre_err

Synthesis of the vulnerability 

An attacker can force a read at an invalid address via ip6gre_err() on the Linux kernel, in order to trigger a denial of service, or to obtain sensitive information.
Vulnerable systems: Blue Coat CAS, Broadcom Content Analysis, Debian, Fedora, Android OS, Linux, openSUSE Leap, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Severity of this threat: 2/4.
Creation date: 06/02/2017.
Références of this weakness: CERTFR-2017-AVI-060, CERTFR-2017-AVI-128, CERTFR-2017-AVI-162, CERTFR-2018-AVI-408, CVE-2017-5897, DSA-3791-1, FEDORA-2017-92d84f68cf, FEDORA-2017-fb89ca752a, openSUSE-SU-2017:0541-1, openSUSE-SU-2017:0547-1, SA148, SUSE-SU-2017:0575-1, SUSE-SU-2017:1247-1, SUSE-SU-2017:1360-1, SUSE-SU-2017:1990-1, USN-3265-1, USN-3265-2, USN-3361-1, USN-3754-1, VIGILANCE-VUL-21764.

Description of the vulnerability 

The Linux kernel support GRE (Generic Routing Encapsulation) tunnels overs IPv6.

However, the ip6gre_err() function tries to read a memory area located outside the expected range, which triggers a fatal error, or leads to the disclosure of a memory fragment.

An attacker can therefore force a read at an invalid address via ip6gre_err() on the Linux kernel, in order to trigger a denial of service, or to obtain sensitive information.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This weakness alert impacts software or systems such as Blue Coat CAS, Broadcom Content Analysis, Debian, Fedora, Android OS, Linux, openSUSE Leap, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Our Vigil@nce team determined that the severity of this computer vulnerability note is medium.

The trust level is of type confirmed by the editor, with an origin of intranet client.

An attacker with a expert ability can exploit this security bulletin.

Solutions for this threat 

Linux kernel: version 4.9.11.
The version 4.9.11 is fixed:
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Linux kernel: version 4.4.50.
The version 4.4.50 is fixed:
  https://cdn.kernel.org/pub/linux/kernel/v4.x/

Linux kernel: version 3.18.49.
The version 3.18.49 is fixed:
  https://cdn.kernel.org/pub/linux/kernel/v3.x/

Linux kernel: version 3.16.41.
The version 3.16.41 is fixed:
  https://cdn.kernel.org/pub/linux/kernel/v3.x/

Linux kernel: version 3.12.71.
The version 3.12.71 is fixed:
  https://cdn.kernel.org/pub/linux/kernel/v3.x/

Linux kernel: version 3.10.106.
The version 3.10.106 is fixed:
  https://cdn.kernel.org/pub/linux/kernel/v3.x/linux-3.10.106.tar.xz

Linux kernel: patch for ip6gre_err.
A patch is indicated in information sources.

Android OS: patches 2017-09-01 and 2017-09-05.
A patch is indicated in information sources.

Blue Coat Content Analysis System: solution for Linux.
The version 2.1.1.1 is partly fixed.

Debian 8: new linux packages.
New packages are available:
  Debian 8: linux 3.16.39-1+deb8u1

Fedora 24: new kernel packages.
New packages are available:
  Fedora 24: kernel 4.9.9-100.fc24

Fedora 25: new kernel packages.
New packages are available:
  Fedora 25: kernel 4.9.9-200.fc25

openSUSE Leap: new kernel packages.
New packages are available:
  openSUSE Leap 42.1: kernel 4.1.38-50.1
  openSUSE Leap 42.2: kernel 4.4.49-16.1

SUSE LE 12 RTM: new kernel packages.
New packages are available:
  SUSE LE 12 RTM: kernel 3.12.61-52.72.1

SUSE LE 12 SP1: new kernel packages.
New packages are available:
  SUSE LE 12 SP1: kernel 3.12.74-60.64.40.1

SUSE LE 12 SP2: new kernel packages.
New packages are available:
  SUSE LE 12 SP2: kernel 4.4.49-92.11.1

SUSE LE 12 SP2: new kernel-rt packages (28/07/2017).
New packages are available:
  SUSE LE 12 SP2: kernel-rt 4.4.74-7.10.1

Ubuntu 14.04: new linux-image-3.13.0 packages.
New packages are available:
  Ubuntu 14.04 LTS: linux-image-generic 3.13.0.157.167

Ubuntu 16.04: new linux-image-generic packages (21/07/2017).
New packages are available:
  Ubuntu 16.04 LTS: linux-image-generic 4.10.0.27.30

Ubuntu: new linux-image-generic 4.4 packages.
New packages are available:
  Ubuntu 14.04 LTS: linux-image-generic-lts-xenial 4.4.0.75.62
  Ubuntu 16.04 LTS: linux-image-generic 4.4.0.75.81
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides a systems vulnerabilities patch. Each administrator can customize the list of products for which he wants to receive vulnerability alerts.