The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of MHonArc: Cross Site Scripting

Synthesis of the vulnerability 

An attacker can send a malformed HTML email, which is not correctly filtered by MHonArc, and creates a Cross Site Scripting.
Vulnerable software: Fedora, Mandriva Linux, MHonArc, Unix (platform) ~ not comprehensive.
Severity of this announce: 2/4.
Creation date: 21/12/2010.
Références of this computer vulnerability: BID-45528, CVE-2010-4524, FEDORA-2011-3357, FEDORA-2011-3390, MDVSA-2011:003, VIGILANCE-VUL-10231.

Description of the vulnerability 

The MHonArc program converts emails to HTML pages, which can then be displayed on a web server.

This program filters the JavaScript code contained in HTML emails. However, if an HTML element is inserted inside another element, the outer HTML element is not filtered. This second element is then displayed by the web server.

An attacker can therefore send a malformed HTML email, which is not correctly filtered by MHonArc, and creates a Cross Site Scripting.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This vulnerability impacts software or systems such as Fedora, Mandriva Linux, MHonArc, Unix (platform) ~ not comprehensive.

Our Vigil@nce team determined that the severity of this security announce is medium.

The trust level is of type confirmed by the editor, with an origin of document.

A proof of concept or an attack tool is available, so your teams have to process this alert. An attacker with a technician ability can exploit this computer vulnerability note.

Solutions for this threat 

MHonArc: version 2.6.17.
The version 2.6.17 is corrected:
  http://www.mhonarc.org/release/MHonArc/tar/

MHonArc: workaround.
A workaround is to disable the display of HTML emails:
  http://www.mhonarc.org/MHonArc/doc/faq/security.html#htmldata
  http://www.mhonarc.org/MHonArc/doc/faq/security.html#htmlexchow
Snapshots posterior to the 30th of December 2010 are corrected:
  http://www.mhonarc.org/release/MHonArc/dist/

Fedora: new mhonarc packages.
New packages are available:
  mhonarc-2.6.18-3.fc13
  mhonarc-2.6.18-3.fc14

Mandriva: new MHonArc packages.
New packages are available:
  Mandriva Linux 2009.0: MHonArc-2.6.18-0.1mdv2009.0
  Mandriva Linux 2010.0: MHonArc-2.6.18-0.1mdv2010.0
  Mandriva Linux 2010.1: MHonArc-2.6.18-0.1mdv2010.2
  Corporate 4.0: MHonArc-2.6.18-0.1.20060mlcs4
  Mandriva Enterprise Server 5: MHonArc-2.6.18-0.1mdvmes5.1
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides system vulnerability patches. The technology watch team tracks security threats targeting the computer system.