The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of Memcached: security improvement for the UDP transport

Synthesis of the vulnerability 

The security of Memcached was improved for UDP transport, which now defaults to disabled to limit the possibilities of DDos reflected attacks (see VIGILANCE-ACTU-5745).
Impacted products: Debian, Fedora, openSUSE Leap, Solaris, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Severity of this bulletin: 1/4.
Creation date: 05/03/2018.
Références of this threat: bulletinjan2019, CVE-2018-1000115, DSA-4218-1, FEDORA-2018-122ea355a7, FEDORA-2018-8ff86925c3, openSUSE-SU-2018:0968-1, SUSE-SU-2018:1326-1, USN-3588-1, VIGILANCE-VUL-25431.

Description of the vulnerability 

The security of Memcached was improved for UDP transport, which now defaults to disabled to limit the possibilities of DDos reflected attacks (see VIGILANCE-ACTU-5745).
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This security vulnerability impacts software or systems such as Debian, Fedora, openSUSE Leap, Solaris, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Our Vigil@nce team determined that the severity of this computer weakness bulletin is low.

The trust level is of type confirmed by the editor, with an origin of internet client.

An attacker with a expert ability can exploit this security note.

Solutions for this threat 

Memcached: version 1.5.6.
The version 1.5.6 is fixed:
  http://memcached.org/files/memcached-1.5.6.tar.gz

Debian 8/9: new memcached packages.
New packages are available:
  Debian 8: memcached 1.4.21-1.1+deb8u2
  Debian 9: memcached 1.4.33-1+deb9u1

Fedora: new memcached packages.
New packages are available:
  Fedora 26: memcached 1.4.39-2.fc26
  Fedora 27: memcached 1.5.7-1.fc27

openSUSE Leap 42.3: new memcached packages.
New packages are available:
  openSUSE Leap 42.3: memcached 1.4.39-11.6.1

Oracle Solaris: patch for third party software of January 2019 v1.
A patch is available:
  https://support.oracle.com/rs?type=doc&id=1448883.1

SUSE LE 11 SP4: new memcached packages.
New packages are available:
  SUSE LE 11 SP4: memcached 1.2.6-5.17.3.1

Ubuntu: new memcached packages.
New packages are available:
  Ubuntu 17.10: memcached 1.4.33-1ubuntu3.2
  Ubuntu 16.04 LTS: memcached 1.4.25-2ubuntu1.3
  Ubuntu 14.04 LTS: memcached 1.4.14-0ubuntu9.2
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides computer security bulletins. The Vigil@nce security watch publishes vulnerability bulletins about threats impacting the information system.