The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of Mercurial: privilege escalation via Protocol Server

Synthesis of the vulnerability 

An attacker can bypass restrictions via Protocol Server of Mercurial, in order to escalate his privileges.
Vulnerable software: Debian, openSUSE Leap, Solaris, RHEL.
Severity of this announce: 3/4.
Creation date: 03/04/2018.
Références of this computer vulnerability: bulletinjan2019, CVE-2018-1000132, DLA-1331-1, DLA-1414-1, DLA-1414-2, DLA-2293-1, openSUSE-SU-2018:0917-1, RHSA-2019:2276-01, VIGILANCE-VUL-25747.

Description of the vulnerability 

An attacker can bypass restrictions via Protocol Server of Mercurial, in order to escalate his privileges.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This security note impacts software or systems such as Debian, openSUSE Leap, Solaris, RHEL.

Our Vigil@nce team determined that the severity of this threat announce is important.

The trust level is of type confirmed by the editor, with an origin of intranet client.

An attacker with a expert ability can exploit this computer weakness announce.

Solutions for this threat 

Debian 7: new mercurial packages.
New packages are available:
  Debian 7: mercurial 2.2.2-4+deb7u7

Debian 8: new mercurial packages.
New packages are available:
  Debian 8: mercurial 3.1.2-2+deb8u6

Debian 9: new mercurial packages.
New packages are available:
  Debian 9: mercurial 4.0-1+deb9u2

openSUSE Leap 42.3: new mercurial packages.
New packages are available:
  openSUSE Leap 42.3: mercurial 4.2.3-12.1

Oracle Solaris: patch for third party software of January 2019 v3.
A patch is available:
  https://support.oracle.com/rs?type=doc&id=1448883.1

RHEL 7: new mercurial packages.
New packages are available:
  RHEL 7: mercurial 2.6.2-10.el7
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides a networks vulnerabilities watch. The Vigil@nce security watch publishes vulnerability bulletins about threats impacting the information system.